Unable to read the PDF Document IMM 008 E Generic

Asked by Anita Thakur on 2016-04-30

Hi..... I am Unable to read the PDF Document IMM 008 E Generic as the form's content are not loading completely. All other PDF Documents are easily readable and no issues are ever faced to open them, but the issue exists with merely this IMM 008 E Generic form. I need to complete this form online so as to lodge a PR Application for Canaa. Hence, I seek the help towards the prevailing issue asap... Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu evince Edit question
Assignee:
No assignee Edit question
Last query:
2016-04-30
Last reply:
2016-05-01

Have you tried Adobe's PDF reader?

Anita Thakur (anita-thakur) said : #2

Yes, I have tried..... While using Dell Inspiron & HP pavilion, Adobe PDF didn't work but I have used a public PC at a cafe today and the document revealed all the contents when I saved the link initially at the desktop. I don't know what's the issue now....

Can you help with this problem?

Provide an answer of your own, or ask Anita Thakur for more information if necessary.

To post a message you must log in.