Install sound card driver for Ubuntu, it works with Windows

Asked by Harry Chestnut on 2006-11-03

I cannot get any sound using Ubuntu. it tells me i don't have a sound card of the streamers are not installed. However; my sound card works with windows. I just don't know where to get the driver and install it. HELP THANKS harry

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evince Edit question
Assignee:
No assignee Edit question
Solved by:
williamts99
Solved:
2006-12-09
Last query:
2006-12-09
Last reply:
2006-12-08
Jeff Greene (jeffgreene) said : #1

Hi, could you please post what sound card you have. You can do so by going to System --> Administration --> Device Manager. Maybe you could also try submitting your specs to the Ubuntu Device Database once you open Device Manager.

Here is a list of some known supported sound cards:
https://wiki.ubuntu.com/HardwareSupportComponentsSoundCards

Please note that if yours is not on there, it may still work.

Jeff Greene (jeffgreene) said : #2

By the way, does sound not work at all, or just with a specific program?

Hi, what make and model of computer do you have?

It would also be useful for us to know what sound card you have. You may be able to find this out in device manager under windows.

Alternatively boot to ubuntu then go to Applications --> Accessories --> Terminal. Maximise the window then type the following command in it:-

lspci

It will list some of the hardware devices in your computer. You might see a sound card listed. If you have an internet connection on the Ubuntu machine you could copy and paste the result of typing that command here.

So for example on my wifes computer I see a line with the word "Audio" in like this:-

 0000:00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio (rev 12)

My sound card is Asound Ver. 2.0 model asoo7 chip:als120
I' tried all the above and non works.

I don;t get any sound at all. MY computer is an older model put together with a piec from here and one from there. thanks harry

Also on the disk I have there is a driver for linux, but it is a tar ball and I don't know how to install it. again thanks

williamts99 (williamts99) said : #7

what happens when you enter the following into the Terminal

sudo modprobe snd-als100

when i enter, sudo modpr obe snd-als100, comand not found. am i doing something wrong

williamts99 (williamts99) said : #9

Please copy and paste the command. There should be no space between modpr obe

i copied and pasted, also i tried typing it in. nothing happens, it jusst jumps to the comand prompt

williamts99 (williamts99) said : #11

Interesting, it doesn't even ask you for your password? After running
the command, have you tested your sound?

No, it does not ask me for my pass word. I have tested the sound
with devic manager and sent the results to the data bank, For what ever good that will do. I thank you so much for your help and any that you give in the future. I've been trying to eleminate this problem for some time. I will not give up on it. Again I thank you. harry

Hi, I am still trying to get my sound card to work. I managed to get it to work yesterday, but I don't remember how, and when I rebooted it was not there anymore. It is listed on this support page. Will you once again try to help me install it. als100
https://wiki.ubuntu.com/HardwareSupportComponentsSoundCards

williamts99 (williamts99) said : #14

Do you think that it was something that you entered into the terminal that corrected your issue? If so you can open up the terminal and press the up arrow key to see commands that you have issued previously.

i will try

It could be but I tried so many things. that it would be hard to try them all again THANKS i will keep trying

williamts99 (williamts99) said : #17

Also, are you using the latest version of Ubuntu, or are you using a previous version?

harry@chestnut:~$ lspci -n 0000:00:00.0 0600: 1022:7006 (rev 25)
0000:00:01.0 0604: 1022:7007 (rev 01)
0000:00:07.0 0601: 1022:7408 (rev 01)
0000:00:07.1 0101: 1022:7409 (rev 07)
0000:00:07.3 0680: 1022:740b (rev 03)
0000:00:07.4 0c03: 1022:740c (rev 06)
0000:00:09.0 0200: 10ec:8029
0000:00:0a.0 0200: 10b7:9200 (rev 78)
0000:00:0b.0 0300: 5333:8a01 (rev 01) does this mean anything
harry@chestnut:~$ 177_i386.deb (DEB FORMAT)
bash: syntax error near unexpected token `DEB'
harry@chestnut:~$
 or this It might work if I could figure out how to fix this

harry@chestnut:~$ modinfo soundcore
filename: /lib/modules/2.6.15-27-386/kernel/sound/soundcore.ko
description: Core sound module
author: Alan Cox
license: GPL
alias: char-major-14-*
vermagic: 2.6.15-27-386 preempt 486 gcc-4.0
depends:
srcversion: DD426F1CCA2CC5F060F6F92
harry@chestnut:~$

As you can see I have been many places, but the fact remains I don't know what I am doing but I am learning

I am using 6.6

it must not 6.6 but it is the latest releasee

How do I get into the sound dir.????????

williamts99 (williamts99) said : #23

Well the good news is that you did have it working, now just to try the things that you tried again and see which one made it work. :-)

----------------------------------------
> To: <email address hidden>
> From: <email address hidden>
> Subject: [Support #2323]: Re: [Support #2323]: Re: install sound card drver for ubuntu, it workds with win
> Date: Sun, 12 Nov 2006 09:15:55 +0000
>
> Support request #2323 on Ubuntu changed:
> https://launchpad.net/distros/ubuntu/+ticket/2323
>
> Comment:
> Well the good news is that you did have it working, now just to try the things that you tried again and see which one made it work. :-)

Thanks for making me smile!!!!!!!!!! I spend hours trying different stuff, I could buy a new card, but I am persistent. This one will work and I am learning at the same time, I am 61 years old, and disabled. So I have plenty of time. Although; I have a bachlors in nuclear medicine and ran some very complicated computer programs, I always had someone to ask. Those programs are alot different than Windows or Linux. I will post some thing from dmesg. Will you please tell me what to do about it???????? [17179569.184000] Local APIC disabled by BIOS (or by default) -- you can enable it with "lapic" It is recognizing the game controller on the same card so there isn't any reasn why I should not be able to get sound to work. I sincerely appreciate your help harry

how do i use lapic?????????????
_________________________________________________________________
Express yourself with gadgets on Windows Live Spaces
http://discoverspaces.live.com?source=hmtag1&loc=us

I think I could get my sound to work if I knew how to use the terminal commands.
These are the commands that are in the gnome terminal manuel, Will some one please tell me how to use them I copy and past and nothing seems to work. Will someone please tell me what I am doing wrong. IN ADVANCE THANKS Harry

GNOME Library
  --disable-sound Disable sound server usage
  --enable-sound Enable sound server usage
  --espeaker=HOSTNAME:PORT Host:port on which the sound
                                                  server to use is running
  --version 2.14.1

Session management
  --sm-client-id=ID Specify session management ID
  --sm-config-prefix=PREFIX Specify prefix of saved
                                                  configuration
  --sm-disable Disable connection to
                                                  session manager

GNOME GUI Library
  --disable-crash-dialog Disable Crash Dialog
harry@harry-desktop:~$

The command, sudo modprobe snd-als100, wooked. When I typed it into the terminal it jumped to the comand prompt. However it did install the driver for my sound card. I just didn't try it. In addition; it does not load when I reboot. Can someone please tell me what to do so I don't have to manually load it.
                     thanks harry
      Will I sincerely all the support you have given me!!!!

Best williamts99 (williamts99) said : #27

In the terminal, enter

sudo gedit /etc/modules

and add

snd-als100

on it's own line.

I think that is all you should have to do.

Hi Will; When I typed, sudo gedit /etc/modules snd-als100, into the terminal, I got the following.

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
psmouse

The box had two tabs. I think I was supposed to paste it into the tab with, snd-als100, on it. Is that what I am supposed to do. thanks harry

williamts99 (williamts99) said : #29

Using 'sudo gedit /etc/modules' will open up the text editor, you will add the line snd-als100 to the bottom and save the file and it will look like this:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
psmouse
snd-als100

BINGO It worked. As I said before, I really appreciate your patience and support. harry

williamts99 (williamts99) said : #31

No problem, I am glad that we could get it to work.

Could you please mark this support request as solved.

https://wiki.ubuntu.com/SupportRequests contains useful information about managing your support request.

Best Regards,

Williamts99

I will most certainly mark this a solved. Please tell me how.
My inexperience is really showing.

I can not close this ticket, because I am haveing problems sighing up to become a ubuntuero. I try to follow the directions but evidently I am not doing something right. Will some one please give me directions that a caveman could follow????????? In advance I thank you. harry

When I first installed UBUNTU 6.03. I didn't have any sound at all. The community (williamts99) showed at lot of patience try to help me. I used the commands he showed me, rhey worked. however I didn't check to see if the driver was installed they were. I just didn't check to see. And they were not reloaded when I booted. The above solved my problem.
Thanks to Will.

The reason I couldn't close the ticked was I have two accounts
The first is Harry Truman, the other Harry Chestnut. Now that I know that I will not have any more problems closing Tickets!!!

This is what solved my problem, and made my sound card work. my sound card is asound gold.

Using 'sudo gedit /etc/modules' will open up the text editor, you will add the line snd-als100 to the bottom and save the file and it will look like this:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
psmouse
snd-als100

   thanks to the ubuntu community

sam (sam08-82) said : #39

I need Help with my sound card... 00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)...
this is the sound card of my laptop from Acer TravelMate 2424NWXCi... my music plays with Rhythmbox Music Player but there is no sound...
i am also using Ubuntu 8.04 with Ubuntu Studio...i am a new user with Linux... could you help me...thanks