Bad user-experience with posters (large documents)

Asked by Norman Hendrich on 2011-12-27

Hi guys,

this one should be easy to fix. On Ubuntu, evince is the default previewer for PDFs, and as such it is also used to preview "posters", meaning documents with paper-size DIN-A1, DIN-A0, or similar, and up. Info says 2.32.0,
this is on Ubuntu/natty.

For poster-sized documents, evince ALWAYS comes up in the largest possible size, meaning filling the complete width of my full-HD monitor, and EVEN full-height, meaning that the evince window hides (or is hidden) beneath my XFCE task-bar.

This is wrong, because:

1) I requested evince to respect the previously selected window size
2) full-width is crazy for A*-sized portrait formats
3) full-width hides a lot of my other windows, showing only blank pixels
4) the original documents is scaled-down anyway.

5) the user has to resize the window
6) which is DIFFICULT, as the bottom-right window-resize corner is actually BELOW the task-bar.

I presume you never tested with large (=large paper-size) documents or posters?
Or did I mis-configure/uninstall something, and evince behaves better on other systems?

Please consider

a) keeping my selected preferences (=the window size when I selected <ctrl+T>, meaning

b) being smart and deciding that full-height (minus task-bar !!!) would be good for portrait-sized
    documents, should you prefer not to keep the user-preferences,

c) avoiding going full-screen (hiding the task-bar, hiding everything else with just blank pixels).


Question information

English Edit question
Ubuntu evince Edit question
No assignee Edit question
Solved by:
Norman Hendrich
Last query:
Last reply:

Have you tried any other viewers?

Norman Hendrich (hendrich) said : #2

Yes, several. On Ubuntu I only have/use Acrobat in addition to evince.

Acrobat starts up with the default window-size selected in its preferences.
On my ancient SuSE system, kpdf starts up with useful window-size as well.
On newer SuSE at work, okular starts up with useful window-size.

Only evince starts up in full-screen format as described above, and I would like it to respect my settings.

In case you want to reproduce it, here is a link to a an example DIN-A0 style poster from latex+sciposter,

try xpdf as an alternative, is it better?

Norman Hendrich (hendrich) said : #4

Hi Andrew,

I still don't see how using a different tool fixes bugs or problems in evince :-)

Perhaps I posted my bug-report in a wrong category? It was meant as feedback regarding a bad user-experience when using evince, which for some reason is the default PDF viewer on my system.

It will give an alternative so you can be productive. You should also report a bug with:

ubuntu-bug evince

Norman Hendrich (hendrich) said : #6

> It will give an alternative so you can be productive. You should also report a bug with

OK thanks.

Somehow, I was under the impression that I did already file a bug report, but indeed this group/thread whatever seems to be just for questions. Sorry for the noise.