Document Viewer unable to open DVI files and PDF files not named *.pdf

Asked by gareth on 2011-01-10

Hi

Have recently upgraded to Ubuntu 10.04, and I notice 2 problems with Document Viewer:

1. DVI files
Info about Document Viewer says it can open DVI files, but I get:
"Unable to Open Document: DVI document has incorrect format". This DVI file was generated by latex on the same system. Okular opens the file without errors or warnings.

2. PDF files without .pdf extension
PDF files downloaded from arxiv.org have a numerical file number, without .pdf extension. Document Viewer gives the error:
"Unable to Open Document: Error Opening File: Permission Denied." Again, Okular opens this file with no problems. I have checked file permissions, and I am the owner, and Others have permission to read the file.
If I add ".pdf" to the end of the filename, Document Viewer opens it without problem. Ubuntu recognises the file as a pdf, so I don't see why I should need to rename each file before opening.

Can give samples of the files I am trying to open if needed.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evince Edit question
Assignee:
No assignee Edit question
Solved by:
gareth
Solved:
2011-01-11
Last query:
2011-01-11
Last reply:
2011-01-11

If you install adobe's reader, is it ok?

gareth (garethbaxter) said : #2

Hi

Sorry, don't really want to install Adobe Reader, as I did so once before and found it very difficult to get rid of. These files did read perfectly in the version of Reader I was using in Ubuntu 8.04 though.
As I said above, I have installed Okular, and it can also display both files perfectly.

You may need it if okular doesn't do what you need.

I suggest you log a bug.

gareth (garethbaxter) said : #4

I have no problems with Okular at all, so I won't be needing Reader.

I was trying to point out a bug in Evince. Since this is the default viewer, it should work as intended.
I will take your advice and log a bug -- it's what I thought I was doing, but I seem to have mixed up the sections.

cheers

gareth (garethbaxter) said : #5

Problem solved in the sense that it is now a bug and not a question.