How to configure Document Viewer to open files at the beginning always?

Asked by AndreyPutilov on 2010-04-21

As default, Ubuntu 9.10 Document Viewer opens files at a place I left reading before. How do I configure it to open files at the beginning always?

Question information

English Edit question
Ubuntu evince Edit question
No assignee Edit question
Solved by:
Zoltán Tősér
Last query:
Last reply:
Sam_ (and-sam) said : #1

manpage says:
              Specifies the file to open when Evince starts. If this is not specified,
              Evince will open a blank window. Multiple files can be loaded if they are sep‐
              arated by spaces. Evince also supports handling of remote files. For exam‐
              ple, you can pass the location on the web or load a file from a FTP server,
              like "".

AndreyPutilov (anputilov) said : #2

You may misunderstand me. I know that I can open a blank window or more then one document at a time. But any document I open is opened somewhere in the middle, where I left reading before. I just want to open any file from the beginning always. I want to see the first page always after opening.

Zoltán Tősér (zozi56) said : #3

I don't think there is any option to set that. Workaround: delete ~/.gnome2/evince/ev-metadata.xml . Though you have to do this every time you want Evince to forget on which pages you left reading.

Sam_ (and-sam) said : #4

Sorry for misinterpretation. According to manpage you could also label a page.
Maybe file a bug at bugzilla (link on manpage) or submit a feature request.

AndreyPutilov (anputilov) said : #5

Thank you, Zoltán Tősér. I found this file, it is simple and it is created every time I close evince window. There is such a line
"<entry key="page" type="gint" value="12"/>"

Thank you, Tom.
It works to launch evince "evince filename --page-label=1" from a shell.
Maybe it is simple to modify a default action on double-click, to open all pdf (and other) documents at the first page. Where to do this? I hope it is safe?

Best Zoltán Tősér (zozi56) said : #6

To set the default action: right click on a pdf file, select properties, go to the "open with" tab, click the "add" button, click "add custom command", and write "evince --page-label=1" (without the quotation marks). Works on my system.

AndreyPutilov (anputilov) said : #7

Thanks Zoltán Tősér, that solved my question.