Gnome Web displays some sites only in mobile version

Asked by JKafle

Ubuntu 21.04.
Gnome Web from the Ubuntu repository displays the sites (Office Online, google search) only in mobile version. Moreover, google shows search results in the language based on location and the option to change language is not working. I could not find a way to change it. However, using the Flatpak version, it displays the sites as desktop versions and these issues are not there. Not that I use google search and office extensively, but I saw this issue and wanted to know if there's a fix to it.

Thank you.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu epiphany-browser Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Bernard Stafford (bernard010) said :
#1

The default browser on Ubuntu is Firefox version 90.
I would suggest using Firefox for now.
Epiphany-browser has 113 bug reports. None the exact same as you have.
You might file a bug report.
Open a terminal and type: ubuntu-bug epiphany-browser
This will start Apport to collect data to go with your bug report.
https://wiki.ubuntu.com/Apport

Revision history for this message
JKafle (jkafle) said :
#2

I use Firefox as my default browser. I frequently check epiphany-browser and get updated with its development.
I checked more thoroughly this time and it seems like the problem is these sites are not displaying the mobile version, rather an older version of their site UI. And, so far only sites I have seen affected are google.com and outlook.com. Here are the images:
https://imgur.com/bJs6BVo
https://imgur.com/sPFH0hX
I checked this in the daily build of Ubuntu 21.10, same is the case in 21.04.
Should I still issue a bug report?

Revision history for this message
Bernard Stafford (bernard010) said (last edit ):
#3

Each browser displays the web site content slightly different. On the same web sites. Firefox displays them the same.
I would conclude that it would be the web site that is displaying a mobile version not the Web browser.
You can file a bug report if you feel it is still needed.

Can you help with this problem?

Provide an answer of your own, or ask JKafle for more information if necessary.

To post a message you must log in.