Epiphany - Remove typed URLS

Asked by DrMindHaxor on 2008-02-24

 I would like to know how to remove the drop-down list of typed URLs from Epiphany.
I have Googled this to no end, I have searched every single file in /home directory
and cannot find anything. Using the history tool does not work. I would prefer to
know the location/name of the file that stores this so I can automate its deletion
with a shell script. I would also like to know how to turn this feature off per se
(I couldn't find anything in about:config, what settings I did change had no effect).

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu epiphany-browser Edit question
Assignee:
No assignee Edit question
Solved by:
Bhavani Shankar
Solved:
2008-02-24
Last query:
2008-02-24
Last reply:
2008-02-24
Best Bhavani Shankar (bhavi) said : #1

.gconf/apps/gnome-settings/epiphany/ I think where the history is stored..

Go->History, and Edit->Clear History should also work.. hmm..

Automated deletion.. As far as I know, there is no option for that in epiphany.

Try this shell script..

#!/bin/bash
#
# start_epiphany_clear_history
#
# This is just a shell script to force epiphany to start clean.
#
# Reason: Redirect error messages (unknown cause) to /dev/null.
#
# Author: Bhavani Shankar, 24-02-2008.
#
# Copyright: There is none! I release this into the public domain
# for you to do with as you wish. Although I don't foresee this causing
# problems, I also assert that I am in no way liable if this breaks
# anything in your computer setup.
#
rm -f ~/.gnome2/epiphany/mozilla/epiphany/Cache/*
rm -f ~/.gnome2/epiphany/mozilla/epiphany/cookies.txt
rm -f ~/.gnome2/epiphany/ephy-history.xml
rm -f ~/.gconf/apps/gnome-settings/epiphany/
epiphany & 2>/dev/null

pretty much does the same things as the Firefox menu Tools --> Clear Private Data.

I hope that this helps..

Bhavani Shankar.

DrMindHaxor (drmindhaxor) said : #2

Bhavani,
 No, that didn't help. I did find those files and tried the "clear history".
I *did* find out, that as I type in say 's' in the location bar that the
drop-down list would populate (that drop-down list is what I was trying
to get rid of) with items from my bookmarks (not all typed URLs).
thanks for the help though,
DrMindhaxor