cannot receive pictures through bluetooth from my mobile phone

Asked by lisamcgrane on 2008-08-10

I am trying to send files to my webbook from my mobile phone but it just says sending failed straight away. Also, when I am browsing a device(my mobile phone which I have connected to through bluetooth it brings up the images but will not open them so they are there but when I try to open them it says 'the given locations contain no images'.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu eog Edit question
Assignee:
No assignee Edit question
Solved by:
Rasmus Dietrich
Solved:
2008-08-12
Last query:
2008-08-12
Last reply:
2008-08-12

You may need to install the gnome-obex-server that comes with the gnome-bluetooth package.

My desktop is in German, so I have to guess the names of the menu entries in English.

The intended way to send files to the PC seems to be the following:
   1) Right click on the bluetooth symbol in the panel
   2) Click on settings
   3) Click on the third tab (should say "general" or something like that)
   4) Activate the third check box (should say something like "authorize incoming connections automatically")

If that doesn't work, it doesn't work for me, installing gnome-bluetooth should solve the problem:
   1a) Either open a terminal and write:
                                               sudo aptitude install gnome-bluetooth
   1b) Or open the "add/remove" program at the end of the application menu,
         search for "gnome-bluetooth"
         install the only program that comes up, this has the advantage of telling you the name the program will have in the application menu.
   2) Now there should be a new entry in Applications --> Accessories with a blue icon representing an antenna, the name should be something like "bluetooth file server".
   3) Opening this program will enable the reception of files sent to the PC. It will put a new icon in the notification area from where it can be terminated.

Hope it works for you, sorry for the convoluted wording, I have to much stuff open to reboot and change language...

lisamcgrane (lisamcgrane19) said : #2

Thanks so much for that, however unfortunately, I was able to install the gnome bluetooth but still cannot send pictures from my phone to the webbook!

What should work is browsing the device and dragging the picture to a folder on your webbook.

The problem with EOG should be caused by EOG not supporting gvfs, so that you have to first move the pictures to a local volume before you are able to open them.
This problem will be solved in the next release of Ubuntu, see the linked bug.

If you wish to move only single pictures you can enable previews for remote volumes under the preview tab in the Nautilus (file manager) setting setting the second drop down menu (show previews for other supported file types) to "always".

The downside of showing previews for the pictures on a remote volumes is that it takes as long for the previews to show as it would to just copy them, as the program has to open every file to create the thumbnail.
I prefer to copy all pictures over as my phone puts them in folders named after the date they have been taken, so I know witch ones I have already on my PC, and erase the ones I don't want to keep.

Lets hope this one works for you, good luck.

lisamcgrane (lisamcgrane19) said : #4

thank u so much, all sorted!