howto install libgl1-mesa-dri, libgl1-mesa-glx and libglapi-mesa version 9.2~git20130628.g6b676e6-0ubuntu0+mir4-jenkins86saucy0

Asked by Fabio Della Lena on 2013-08-23

I logged the Bug 1213870 and as a reply I got an advice to upgrade the following libraries:

libglapi-mesa version 9.2~git20130628.g6b676e6-0ubuntu0+mir4-jenkins86saucy0 required, but 9.1.6-2ubuntu2 is available
libglib2.0-data version 2.37.6-1ubuntu1 required, but 2.37.5-1ubuntu1 is available
libglib2.0-0 version 2.37.6-1ubuntu1 required, but 2.37.5-1ubuntu1 is available
libgl1-mesa-dri version 9.2~git20130628.g6b676e6-0ubuntu0+mir4-jenkins86saucy0 required, but 9.1.6-2ubuntu2 is available
libgl1-mesa-glx version 9.2~git20130628.g6b676e6-0ubuntu0+mir4-jenkins86saucy0 required, but 9.1.6-2ubuntu2 is available

Which repository I have to download from?

I tried downloading the libraries manually from https://launchpadlibrarian.net/145237781 but I get some errors installing:

dpkg: error processing libgl1-mesa-dri_9.2~git20130628.g6b676e6-0ubuntu0+mir4-jenkins86saucy0_amd64.deb (--install):
 trying to overwrite shared '/usr/share/doc/libgl1-mesa-dri/changelog.Debian.gz', which is different from other instances of package libgl1-mesa-dri:amd64
dpkg: error processing libgl1-mesa-glx_9.2~git20130628.g6b676e6-0ubuntu0+mir4-jenkins86saucy0_amd64.deb (--install):
 trying to overwrite shared '/usr/share/doc/libgl1-mesa-glx/changelog.Debian.gz', which is different from other instances of package libgl1-mesa-glx:amd64
trying to overwrite shared '/usr/share/doc/libglapi-mesa/changelog.Debian.gz', which is different from other instances of package libglapi-mesa:amd64

Any help?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu eog Edit question
Assignee:
No assignee Edit question
Last query:
2013-08-23
Last reply:
2013-08-24

i suggest you report a bug. Saucy is not ready and not stable. If you cannot resolve issues (like this) then you should avoid prereleases, they are not for the average user.

Can you help with this problem?

Provide an answer of your own, or ask Fabio Della Lena for more information if necessary.

To post a message you must log in.