How do I open click packages?

Asked by Anupam on 2016-07-05

Engrampa (version1.14.1) shows "Archive type not supported" error while opening .click packages. Is there any way to open and extract .click packages using Engrampa?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu engrampa Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2016-07-05
Last query:
2016-07-05
Last reply:
2016-07-05

What is the output of:

lsb_release -a; uname -a; apt-cache policy engrampa

Thanks

Anupam (anupam207) said : #2

@andrew-woodhead666
Output of lsb_release -a; uname -a; apt-cache policy engrampa:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04 LTS
Release: 16.04
Codename: xenial
Linux mylaptop 4.4.0-28-generic #47-Ubuntu SMP Fri Jun 24 10:09:13 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

engrampa:
  Installed: 1.14.1-1~xenial1.01
  Candidate: 1.14.1-1~xenial1.01
  Version table:
 *** 1.14.1-1~xenial1.01 500
        500 http://ppa.launchpad.net/ubuntu-mate-dev/xenial-mate/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
     1.12.0-2 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

You are using a PPA and not the official Ubuntu package. I suggest you uninstall the application then remove the PPA and install the Ubuntu version. Does it then work OK?

Anupam (anupam207) said : #4

I'm using the one that comes with official Ubuntu MATE distro. I'll raise a bug against Ubuntu MATE then.

You are using the Ubuntu-mate-dev PPA. The version in the default repositories is at version 1.12.0 whereas yours is from at version 1.14.1 and obviously doesn't work. If you remove the PPA you have added and uninstall the application and run:

sudo apt-get clean

You can then install the software from the official Ubuntu repository at version 1.12.0 and it will probably work.

Anupam (anupam207) said : #6

Oh, sorry I forgot I added Ubuntu-mate-dev PPA sometime back. I removed Emgrampa and installed File-roller. It works fine. Thanks for your support.

If you start adding random PPAs then results cannot be guaranteed.

Please mark as solved

Anupam (anupam207) said : #8

Thanks actionparsnip, that solved my question.