Why is empathy 3.8 or 3.9 still not backported to Ubuntu precise

Asked by Rohan "HEXcube" Villoth

The current Empathy (ver in Ubuntu 12.04.3 Precise Pangolin doesn't work with facebook chat at all. A backport of Raring or Saucy's Empathy is needed.

Question information

English Edit question
Ubuntu empathy Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

I suggest you report a bug

Revision history for this message
Manfred Hampl (m-hampl) said :

I am sure that this would have already been done, if that were an easy task.
The problem is that empathy 3.8 (or 3.9) depends on a load of other packages and package versions, that are not available for precise yet.
All those other packages would have to be backported to precise first, before one can build the new empathy version for precise.

Have you already tried compiling that new version yourself?
Most probably a lot of people would be deeply grateful to you if you succeed in building a PPA with empathy 3.8/3.9 (and its dependencies) for precise.

You could create a request for a backport (by creating a bug document against precise-backports, and stating the benefits that the new release would bring for precise, see https://wiki.ubuntu.com/UbuntuBackports for the details of the process), but I doubt that this would be taken up soon.

Revision history for this message
Rohan "HEXcube" Villoth (hexcube) said :

i tried to get compile Quantal empathy package and compile it for Ubuntu Precise. But it had a GTK 3.5 dependency. GTK in precise is 3.4 . Even if i get 3.5 GTK,it won't be a natural solution. Now i realise the fact in Manfred Hampl's answer. i think Empathy is tightly integrated with Gnome environment. As Ubuntu precise is built on gtk 3.4, all gnome apps have versions around 3.4. It'll be difficult to backport 3.8 or even 3.6 empathy. But, some fix has to be done for the bug,coz
1.Precise is an LTS supported till 2017. If nothing is done,the bug will continue till 2017.
2.Empathy being a Chat Client is one of the core apps in Social Network integration. Users who find that they can't even chat on FB will be disappointed.

Revision history for this message
Best Manfred Hampl (m-hampl) said :

It seems that the approach of backporting the 3.8 or 3.9 version of empathy to Ubuntu precise is not feasible.

But maybe there are good news:
It seems that the root cause of the problem "'Facebook Requires Authorization' when already authorized" might have been identified, and work on that issue is on its way, see https://bugs.launchpad.net/ubuntu/+source/telepathy-gabble/+bug/1170832

Revision history for this message
Rohan "HEXcube" Villoth (hexcube) said :

Thanks Manfred Hampl, that solved my question.

Revision history for this message
Rohan "HEXcube" Villoth (hexcube) said :

I installed pidgin too and while using it, one of the facebook accounts in Empathy(which i did through the Jabber/XMPP configuration method) worked. This account which had earlier shown "netwok error" now shows my fb stats. Both empathy and pidgin are showing my chats at the same time. So,i quit pidgin and worked with Empathy alone and it works fine. i think the only problem is initial authorisation. I think i've found atleast a temporary workaround - to use pidgin to pass this barrier and then start using Empathy.

Revision history for this message
Rohan "HEXcube" Villoth (hexcube) said :

Well, my question itself was pretty stupid! It took me quite some time for me to realize that. Now that I've realized it, I'm answering this question properly:

It's infeasible to port Empathy 3.6 or up to precise, coz Ubuntu 12.04 "Precise" runs GNOME/GTK3.4. The entire GNOME stack is tightly integrated. Means that all apps in a particular GNOME release is written in that particular GTK version. For eg; All apps in the GNOME3.4 suite is written in GTK3.4. Apps that are part of a higher GNOME release like GNOME3.6 or GNOME3.8 will have dependencies on higher GTK versions. To installing those packages in Ubuntu 12.04, the GNOME/GTK packages has to be upgraded to the corresponding higher version. Doing this is impractical or even if you manage to do it, the system'll become quite unstable. By doing that much amount of manual upgrades you would've manually upgraded your Ubuntu to a higher release. So, it's better to stay on the GNOME/GTK version which came bundled with that particular Ubuntu release.

Another option is backporting Empathy 3.8 or 3.6 to GTK3.4. Though this is possible, when the lack of purpose for such a backport and the amount of effort required to do that is considered, doing so is unnecessary.

The 3rd and the most practical option is patching Empathy 3.4 with necessary fixes and maybe improvements from upstream. This is what Ubuntu did. Ubuntu made a patched version of Empathy (version and released it on the updates repo. This version solves the problems with Empathy.