Problem installing DELL ATI M3 driver in Ubuntu?

Asked by Murray Ball

I can not see certain windows because my resolution is set to 800x600. I need 1024 resolution. I downloaded the DELL ATI M3 LINUX graphics driver to downloads. I can not find a way to install it. Is there a folder I need to put the files to so Ubuntu 10.10 can automatically install the driver? Any solution will be much appreciated!

Question information

English Edit question
Ubuntu empathy Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Can you give the output of:

sudo lshw -C display


Revision history for this message
Murray Ball (yorktech) said :

 *-display UNCLAIMED
       description: VGA compatible controller
       product: Rage Mobility M3 AGP 2x
       vendor: ATI Technologies Inc
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 02
       width: 32 bits
       clock: 66MHz
       capabilities: agp agp-2.0 pm vga_controller bus_master cap_list
       configuration: latency=32 mingnt=8
       resources: memory:f8000000-fbffffff ioport:ec00(size=256) memory:fdffc000-fdffffff memory:fd000000-fd01ffff

Thank you very much and please, bare with me! I just switched over from Windows. I believe the native resolution before was larger, because some of Ubuntu's windows the bottoms are cut off. Especially Evolution mail? I used the same system for OpenSUSE, and the driver from DELL worked through their software installer. Is there anyway to manually install the driver, also I am having problems logging into the root???

Revision history for this message
actionparsnip (andrew-woodhead666) said :

You NEVER log in as root, it is neither necessary, nor supported. Your user is a member of the group 'admin' and can use sudo and gksudo to run apps as root, the acount is disabled in Ubuntu and this keeps your system more SECURE. The faster you forget root, the better.

The native resolution will be larger, however your system isn't currently configured to use it yet.

If you run:

gksudo gedit /etc/X11/xorg.conf

add this code:

Section "Device"
 Identifier "Configured Video Device"

Section "Monitor"
 Identifier "Configured Monitor"
 Option "DPMS"
 HorizSync 28-70
 VertRefresh 43-60

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
 SubSection "Display"
  Depth 16
  Modes "1024x768" "800x600"

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"

Save the new file, close gedit and restart. If the system doesn't give you a good display then reboot, hold shift and select recovery mode, then select root, you can now run:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf_old

NOTE: The X in X11 is CAPITALIZED, this is important as Linux is very case sensitive.

Renaming the file then rebooting will get you back to the desktop.


Revision history for this message
actionparsnip (andrew-woodhead666) said :

Actually, change:

Section "Device"
 Identifier "Configured Video Device"


Section "Device"
Identifier "Configured Video Device"
Driver "ati"
BusID "PCI:1:0:0"
VideoRam 8192
Option "AgpMode" "2"
Option "EnablePageFlip" "true"
Option "Accel" "true"

Should be a bit better

Can you help with this problem?

Provide an answer of your own, or ask Murray Ball for more information if necessary.

To post a message you must log in.