Personal File Sharing requires packages not installed on my system

Asked by Paco Rocha on 2010-09-17

I want to share a hard drive connected to my PC but when trying to enable Personal File Sharing I get the following message:

Share files over the network

This feature cannot be enabled because the required packages are not installed on your system.

As far as I can see on the Software Centre, Personal File Sharing is installed. Is there anything else that is needed to enable this option?

Thank you for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu empathy Edit question
Assignee:
No assignee Edit question
Solved by:
Marc Stewart
Solved:
2010-09-18
Last query:
2010-09-18
Last reply:
2010-09-17

You have to install Samba. Open System>Administration> Synaptic Package Manager, and find package named samba, and install it.

Best Marc Stewart (marc.stewart) said : #2

The two packages you need to install to activate that are:
apache2
libapache2-mod-dnssd

You may need to restart after installing them, but it worked for me without it.

Paco Rocha (jose-jose8) said : #3

Thanks Marc Stewart, that solved my question.