UNCLAIMED Wireless Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:8172] (rev 10) -> wireless Realtek driver not installed on Toshiba Satellite L450D in Ubuntu 9.10

Asked by coley72676@hotmail.com on 2010-04-03

Downloaded Ubuntu using windows, everything ran as said, only thing is i cant seem to connect to my wireless network. It only has the option to connect to a wired connection and VPN. Also I dont have the NM just the symbol that shows wired. I can switch back to windows and get on the internet through my wireless connection but i am not able to do it in ubuntu. i can connect using an ethernet cord but i want to use it in my bedroom wirelessly!!!!! help!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu empathy Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2010-04-05
Last query:
2010-04-05
Last reply:
2010-04-04

Hi,

Please first connect your network card to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1: Open Terminal from "Applications->Accessories->Terminal"

Step 2: Please copy-paste the following command from the https://answers.launchpad.net/ubuntu website in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word restart. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo lshw -C network; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | grep ound; dmesg | grep b43; dmesg | grep wl; dmesg | grep witch; iwconfig; grep b43 /etc/modprobe.d/*; grep wl /etc/modprobe.d/*; sudo /etc/init.d/networking restart

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Step 4: Please also specify the exact model and make of your PC (if known) on this thread

Regards,

Mark

Vitaliy Kulikov (slonua) said : #2

nice guide by Mark ;) could u convert it to F.A.Q.

i think that u don't have enabled drivers for ur wifi module .. so go to 'hardware drivers' and enable STA driver, if u have broadcom.

also, u can use following command from terminal

$ jockey-text -l

(check output ... possibly u will see 'bcmwl')

$ jockey-text -e bcmwl

Vitaliy Kulikov (slonua) said : #3

nice guide by Mark ;) could u convert it to F.A.Q.

i think that u don't have enabled drivers for ur wifi module .. so go to 'hardware drivers' and enable STA driver, if u have broadcom.

also, u can use following command from terminal

$ jockey-text -l

(check output ... possibly u will see 'bcmwl')

$ jockey-text -e bcmwl

*-network UNCLAIMED
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:0e:00.0
       version: 10
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: ioport:a000(size=256) memory:f0200000-f0203fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:14:00.0
       logical name: eth0
       version: 02
       serial: 00:26:22:3f:c9:c4
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.1.33 latency=0 link=yes multicast=yes port=MII speed=100MB/s
       resources: irq:27 ioport:b000(size=256) memory:f0410000-f0410fff(prefetchable) memory:f0400000-f040ffff(prefetchable) memory:f0420000-f043ffff(prefetchable)
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu 9.10"
00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS780 Host Bridge [1022:9600]
00:01.0 PCI bridge [0604]: Toshiba America Info Systems Device [1179:9602]
00:06.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2) [1022:9606]
00:07.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 3) [1022:9607]
00:11.0 SATA controller [0106]: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode] [1002:4391]
00:12.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
00:12.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
00:12.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
00:13.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 3a)
00:14.1 IDE interface [0101]: ATI Technologies Inc SB700/SB800 IDE Controller [1002:439c]
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB700/SB800 LPC host controller [1002:439d]
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] HyperTransport Configuration [1022:1300] (rev 40)
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] Family 11h [Turion X2, Athlon X2, Sempron] Address Map [1022:1301]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] DRAM Controller [1022:1302]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] Miscellaneous Control [1022:1303]
00:18.4 Host bridge [0600]: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] Link Control [1022:1304]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics] [1002:9612]
01:05.1 Audio device [0403]: ATI Technologies Inc RS780 Azalia controller [1002:960f]
0e:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:8172] (rev 10)
14:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 04f2:b070 Chicony Electronics Co., Ltd
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
H/W path Device Class Description
==================================================
                           system Satellite L450D
/0 bus NBWAE
/0/0 memory 109KiB BIOS
/0/4 processor AMD Sempron(tm) SI-42
/0/4/5 memory 64KiB L1 cache
/0/4/6 memory 512KiB L2 cache
/0/d memory 2GiB System Memory
/0/d/0 memory DIMM DDR2 667 MHz (1.5 ns) [empty]
/0/d/1 memory 2GiB DIMM DDR2 Synchronous 667 MHz (1.5 n
/0/100 bridge RS780 Host Bridge
/0/100/1 bridge Toshiba America Info Systems
/0/100/1/5 display RS780M/RS780MN [Radeon HD 3200 Graphics]
/0/100/1/5.1 multimedia RS780 Azalia controller
/0/100/6 bridge RS780 PCI to PCI bridge (PCIE port 2)
/0/100/6/0 network Realtek Semiconductor Co., Ltd.
/0/100/7 bridge RS780 PCI to PCI bridge (PCIE port 3)
/0/100/7/0 eth0 network RTL8101E/RTL8102E PCI Express Fast Ethern
/0/100/11 scsi1 storage SB700/SB800 SATA Controller [AHCI mode]
/0/100/11/0 /dev/sda disk 160GB Hitachi HTS54321
/0/100/11/0/1 /dev/sda1 volume 400MiB Windows NTFS volume
/0/100/11/0/2 /dev/sda2 volume 74GiB Windows NTFS volume
/0/100/11/0/3 /dev/sda3 volume 74GiB Windows NTFS volume
/0/100/11/1 /dev/cdrom disk CDDVDW TS-L633C
/0/100/12 bus SB700/SB800 USB OHCI0 Controller
/0/100/12.1 bus SB700 USB OHCI1 Controller
/0/100/12.2 bus SB700/SB800 USB EHCI Controller
/0/100/13 bus SB700/SB800 USB OHCI0 Controller
/0/100/13.1 bus SB700 USB OHCI1 Controller
/0/100/13.2 bus SB700/SB800 USB EHCI Controller
/0/100/14 bus SBx00 SMBus Controller
/0/100/14.1 storage SB700/SB800 IDE Controller
/0/100/14.2 multimedia SBx00 Azalia (Intel HDA)
/0/100/14.3 bridge SB700/SB800 LPC host controller
/0/100/14.4 bridge SBx00 PCI to PCI Bridge
/0/101 bridge Mobile K10 [Turion X2, Athlon X2, Sempron
/0/102 bridge Family 11h [Turion X2, Athlon X2, Sempron
/0/103 bridge Mobile K10 [Turion X2, Athlon X2, Sempron
/0/104 bridge Mobile K10 [Turion X2, Athlon X2, Sempron
/0/105 bridge Mobile K10 [Turion X2, Athlon X2, Sempron
/1 power TOSHIBA
Linux ubuntu 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux
[ 0.000000] found SMP MP-table at [ffff8800000f7de0] f7de0
[ 0.000000] No AGP bridge found
[ 1.951059] ACPI: No dock devices found.
[ 2.090116] pnp: PnP ACPI: found 11 devices
[ 2.477754] ehci_hcd 0000:00:12.2: applying AMD SB600/SB700 USB freeze workaround
[ 2.490151] hub 1-0:1.0: USB hub found
[ 2.490375] ehci_hcd 0000:00:13.2: applying AMD SB600/SB700 USB freeze workaround
[ 2.510150] hub 2-0:1.0: USB hub found
[ 2.574107] hub 3-0:1.0: USB hub found
[ 2.645574] hub 4-0:1.0: USB hub found
[ 2.704132] hub 5-0:1.0: USB hub found
[ 2.764168] hub 6-0:1.0: USB hub found
[ 2.784173] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 2.785664] powernow-k8: Found 1 AMD Sempron(tm) SI-42 processors (1 cpu cores) (version 2.20.00)
[ 2.786283] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 3.000026] ata2: applying SB600 PMP SRST workaround and retrying
[ 3.000046] ata4: applying SB600 PMP SRST workaround and retrying
[ 11.570612] lp: driver loaded but no devices found
[ 12.487321] uvcvideo: Found UVC 1.00 device CNF7051 (04f2:b070)
[ 26.276464] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.
[ 0.013222] SMP alternatives: switching to UP code
[ 0.160000] ACPI: EC: non-query interrupt received, switching to interrupt mode
[ 0.690002] ACPI: EC: missing confirmations, switch off interrupt mode.
[ 1.980023] Switched to high resolution mode on CPU 0
[ 2.315699] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input2
[ 2.315795] ACPI: Lid Switch [LID]
[ 37.340020] hda-intel: azx_get_response timeout, switching to polling mode: last cmd=0x00170503
[ 38.350012] hda_intel: azx_get_response timeout, switching to single_cmd mode: last cmd=0x00170503
lo no wireless extensions.

eth0 no wireless extensions.

/etc/modprobe.d/blacklist.conf:# replaced by b43 and ssb.
/etc/modprobe.d/blacklist-watchdog.conf:blacklist twl4030_wdt
 * Reconfiguring network interfaces... Ignoring unknown interface eth0=eth0.
                                                                         [ OK ]
nicholes@ubuntu:~$

This isnt working for me not sure what I am doing but still no luck.. I am kinda techy but I guess its not my day..... Please can some on show me a simplified way of doing this cause im following the directions but its not working.

Oh and I forgot to mention that I downloaded Ubuntu using WUBI?? dont now if that makes a difference, cause i dont wanna partition my hard drive......i like it the way it is, just want to use it wireless cause thats what I have in my home.

Thanks Mark Rijckenberg, that solved my question.

After Sitting down and taking my time I finally fixed this issue.

I want to say a very special thank you to Mark. I needed to follow directions and I must say that you were totally correct with this.....

I was at my wits end and I even went as far as to remove Ubuntu from my thoughts and cyber mind.... thank Mark I didn't. I am using Xubuntu cause I liked the look of it. I have just one question I still have that tar file on my desktop where is a good place to keep it?? gonna read Xubuntu so i can learn how to use it but LOVING THE FEELING ALREADY...

Sent wirelessly from my Bedroom!!!!

thanks.

Omer Akram (om26er) said : #10

 >I have just one question I still have that tar file on my desktop where is a good place to keep it??

upload it to one.ubuntu.com and you can download it any time :)