UI Freeze in 9.10 Beta using Emerald Window Decorator

Asked by Nabialek

Hi, I've been trying out the 9.10 beta and have for the most part been impressed. However, I've been having a play with Boa Constructor in an attempt to create a useful GUI in Python and I regularly get a complete freeze of the UI. No mouse, no keyboard, nothing. I have to restart the machine. This has also been happening when the screen saver has been active, again only when Boa Constructor is open.

My test machine is fairly old and it's disk is getting to the point that it needs to be replaced, but these issues seem to be new to the 9.10 upgrade on my machine. I've tried a clean install on a VM and this has none of these issues.

I did have an install of alfresco on my machine which managed to block several updates in the original upgrade, so I'm wondering if I might have an inconsistent update. Any ideas?

As a developer myself, I know this is fairly lame in terms of useful detail, but when you're frozen out, there's nothing that can be done to get any useful information, so I'm reduced to pattern recognition and deduction. I wouldn't dream of raising this as a bug - far too vague. I may try a complete clean install and see if that improves matters.

Upon further testing I found the same problem happened with a lot of windows, just that there was more window activity when using Boa Constructor. I tried switching my window decorator under Compiz from Emerald to GTK and all seems fine, now.
The problem seems to be related to the interaction between Emerald and the new Compiz components.

TIA for any useful steers.

Question information

English Edit question
Ubuntu emerald Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Sam_ (and-sam) said :
Revision history for this message
marcobra (Marco Braida) (marcobra) said :

I have quick tested the boa-constructor python ide interface now (btw not deeply tested) and it works fine...

Please test your pc ram (a) and force a disk check (b)

(a) ----------------------------

To test your pc RAM memory chips:

- boot your pc press ESC when you see the GRUB row and jump to step "**"


- boot from Ubuntu live cd main menu and at first showed menu and

**) select the item "Memory test" to test your pc ram memory

Please run memory test for many hours or stop it and replace your memory chip if you get errors (the errors usually are rows in red colour)

If you have more than one memory chips plugged on your motherboard, to know which is the damaged
chip please run the memory test with only one chip plugged a time.

(b) ----------------------------
Force filesystem check

Please open a Terminal from the menu Applications → Accessories → Terminal and type:

sudo touch /forcefsck

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

Can you help with this problem?

Provide an answer of your own, or ask Nabialek for more information if necessary.

To post a message you must log in.