Embryo 1.2.0 build fails in Precise (dpkg-gensymbols: warning: some symbols or patterns disappeared in the symbols file), but no problems in Quantal

Asked by Mantas Kriaučiūnas on 2013-01-02

Embryo 1.2.0 build fails in Precise, see https://launchpad.net/~baltix-members/+archive/ppa/+build/4184843

   dh_makeshlibs -a
dpkg-gensymbols: warning: some symbols or patterns disappeared in the symbols file: see diff output below
dpkg-gensymbols: warning: debian/libembryo1/DEBIAN/symbols doesn't match completely debian/libembryo1.symbols
--- debian/libembryo1.symbols (libembryo1_1.2.0-1_i386)
+++ dpkg-gensymbolsFGpIFT 2013-01-02 07:39:56.000000000 +0000
@@ -1,9 +1,9 @@
 libembryo.so.1 libembryo1 #MINVER#
- _embryo_args_init@Base 1.2.0
- _embryo_fp_init@Base 1.2.0
- _embryo_rand_init@Base 1.2.0
- _embryo_str_init@Base 1.2.0
- _embryo_time_init@Base 1.2.0
+#MISSING: 1.2.0-1# _embryo_args_init@Base 1.2.0
+#MISSING: 1.2.0-1# _embryo_fp_init@Base 1.2.0
+#MISSING: 1.2.0-1# _embryo_rand_init@Base 1.2.0
+#MISSING: 1.2.0-1# _embryo_str_init@Base 1.2.0
+#MISSING: 1.2.0-1# _embryo_time_init@Base 1.2.0
  embryo_data_address_get@Base 0.9.1.042
  embryo_data_heap_pop@Base 0.9.1.042
  embryo_data_heap_push@Base 0.9.1.042
dh_makeshlibs: dpkg-gensymbols -plibembryo1 -Idebian/libembryo1.symbols -Pdebian/libembryo1 returned exit code 1

but there are no build problems with the same source package in Quantal, see

https://launchpad.net/~ubuntu-backports-testers/+archive/ppa/+sourcepub/2906709/+listing-archive-extra

I don't understand why build from the same source fails when building for Ubuntu 12.04 (precise), maybe I should use newer version of dpkg-dev or debhelper?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu embryo Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2013-01-02
Last query:
2013-01-02
Last reply:
2013-01-02
Mantas Kriaučiūnas (mantas) said : #1

It seems problem was in older dpkg (or dpkg-dev) version, which is in Ubuntu 12.04 (Precise) - I've copied backported dpkg 1.16.7ubuntu3 into Baltix-Members PPA and now embryo 1.2.0 builds fine for Ubuntu 12.04 :)
Btw, I've found simmilar problem described in bug #935394

Mantas Kriaučiūnas (mantas) said : #3

actionparsnip (andrew-woodhead666) said 6 hours ago:
> Why not just use this PPA
> https://launchpad.net/~lukasmaerdian/+archive/shr?field.series_filter=precise

Thanks for tip, it seems these packages are backported for smart phones (SHR-Project), but should work fine on desktop too ;)

Mantas Kriaučiūnas (mantas) said : #4

Thanks actionparsnip, that solved my question.