How to Input chinese character in emacs ?

Asked by hackrole on 2012-09-14

hello, I am a primary program engineer. Now I use Unbuntu 12.04 as my OS. And I want to learn to use Emacs now. But question is I just can't input any Chinese character. So really hope for help.

The situation now is the when I use the graphics emacs with "emacs -n" ,and press "ctrl-space" to switch to my fcitx input-method,
it just do something I can't really understand. And after searching on the Internet, I get the message that I shuold have to unbind the key which bind to the ctrl-space. But after this, it does not work out , the emacs now just output that the C-space is undifned.

And as I use the emacs 23 which is said to support the multinational language well. So I try to run emacs in the terminal by
"emacs -nw", now the "ctrl-space " is working fine. But the quesiton is that what all I input came to be like that "\232\242?\123" ,
my file is coding with utf-8 . And my environment's content is like that:

daipeng@ubuntu:/etc$ cat environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
http_proxy="http://127.0.0.1:8087/"
https_proxy="https://127.0.0.1:8087/"

# emacs
#LANGUAGE="en_US:en_GB:en"

#LANG=en_US

#LC_CTYPE=zh_CN.GBK

Hope for some help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu emacs24 Edit question
Assignee:
No assignee Edit question
Solved by:
Shahar Or
Solved:
2012-09-17
Last query:
2012-09-17
Last reply:
2012-09-16
hackrole (daipeng123456) said : #2

yes, I have found that by myself. And anyway thank you very much.

hackrole (daipeng123456) said : #3

Thanks Shahar Or, that solved my question.