Emacs23 Unity integration in Ubuntu 12.04 does not work

Asked by Niels Skou Olsen on 2012-04-29

I have just made a fresh install of Ubuntu 12.04, and I'm having problems with GNU Emacs 23.3.1 installed with the software center.

When I start emacs, there is no icon in the launcher, and the emacs windows are not present in the ALT-TAB list.

I should say that I'm running this on a Mac under Parallels 7, so I would like to hear if anyone not running in this environment can reproduce this?

This was working fine in my 11.04 and 11.10 installations, so it seems to be something that 12.04 introduced.

Thanks,
Niels

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu emacs23 Edit question
Assignee:
No assignee Edit question
Solved by:
Niels Skou Olsen
Solved:
2012-04-30
Last query:
2012-04-30
Last reply:
2012-04-29

The install method is moot, the OS is the same.

I suggest you report a bug

Niels Skou Olsen (1-nielz-k) said : #2

Yeah, you're probably right. But I really wanted someone to confirm the problem before I file a bug report.

Btw., the OS is not_exactly_ the same, since Parallels installs its guest tools, which includes kernel modules. But in this case they are probably not causing the problem.

So, would someone please check this out on a non-Parallels installation?

Niels Skou Olsen (1-nielz-k) said : #3

Hmm, now it works as expected. I'm not sure what fixed it, maybe a reboot. I haven't changed any configuration settings or installed anything, so something is weird.

I'll keep an eye on it.