no video directory after inserting usb logitech messenger webcam

Asked by Leonidstachenko

unlike twfjr, who at least can open the video directory, I can't even do that.,it is absent.
The wecam is slotted into the usb plug. I compiled spca5xx using module-assistant.. I have tried xwatv and camorama with no success.
listusb shows ID 046d:08da Logitech, Inc..
any clues as why there is no /dev/video?

Question information

English Edit question
Ubuntu ekiga Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
williamts99 (williamts99) said :

When you cat /proc/modules does the gspca module show up? Also, did you manually modprobe gspca

This is what I used to install mine but I believe that there is a newer version.

sudo apt-get install build-essential linux-headers-$(uname -r)
tar zxvf gspcav1-20070426.tar.gz
cd gspcav1-20070426/
sudo make install
sudo modprobe gspca

Revision history for this message
Leonidstachenko (leonid2) said :

Thanks williams99.
From the hardware support components multimedia webcam table,, it is indicated that the driver for Quick cam messenger model is spca5xx easy to get with module-assistant. I probably fouled up trying to compile it. What logitech model do you have? I see that the communicate model requires gspcav1 driver. Would you suggest that the latter would also work with the messenger model? I tried what you suggested. i.e. cat/proc/modules, i got all sorts of things but no gspca nor spca5xx.. I would appreciate your opinion. Meanwhile I shall install gspcav1 just in case .
Len. .

Revision history for this message
Leonidstachenko (leonid2) said :

Thanks again Williams99.
I have, indeed proceeded in a similar way to your set-up with a more recent gspca and it appears to work. I get a picture with camorama and also with ekiga. Now I have to learn how to make a call correctly. When i place a call I don'know what i am supposed to hear appart from the busy tone and an abnormal stop alrhough i can still see my face in rhe widow. I sould not disconnect so i used the quit key. Any suggestions?

Revision history for this message
Best williamts99 (williamts99) said :

gspca is the replacement for spca5xx :-)

As far as the issue with ekiga, I haven't really used it enough to give advice on it, I recommend that you close this ticket and open a new one for your new problem.

Best Regards,

Revision history for this message
Leonidstachenko (leonid2) said :

thanks again william99,
gspca appears to do the job. One last question Should i get rid of all of the spca5xx files as they are of no use? . The problem is thus solved in that respect.

Revision history for this message
williamts99 (williamts99) said :

Yes, there is really no need for them anymore, it would be fine to get rid of them.

Best Regards,

Revision history for this message
sbur (ch-mere-porteuse) said :

I tried to install gspcav1 for my Logitech Quickcam Messenger 046d:08da. Problems with audio playback, audio capture, and such. I didn't succeed in installing gspcav1. I have kernel 2.6.27-7-generic. I think I saw that gspcav1 worked up to 2.6.16. What do I do with Intrepid?