Could not open Audio channel for audio error - HP Pavilion dv 2500

Asked by PeterDz on 2009-02-23

I get the following message when trying to run Ekiga on my HP dv 2500 under 8.10:

"Could not open audio channel for audio reception

An error occured while trying to play audio to the soundcard for the audio reception. Please check that your soundcard is not busy and that your driver supports full-duplex.
The audio reception has been disabled."

Sound card passes Ubuntu standard tests. Standard Ubuntu drivers, no proprietary drivers.

ADSL rates are nothing to write home about: 1.7 down /0.8up. If I call I get the above when I get through, if I get someone to call in then most times I am able to hear them. I am mostly using SPEEX and I have a local ADSL modem with NAT. I am using STUN for NAT traversa. DTMF is RFC2833, H.245 is enabled DTMF is sent as a string. Audio plugin is ALSA. Input and output devices are both HDA Intel. Runs over a, 11g wireless network.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ekiga Edit question
Assignee:
No assignee Edit question
Last query:
2009-02-24
Last reply:
2009-02-25
PeterDz (pdzwig) said : #2

Nope, sorry - it doesn't! I made the changes as suggested and got no improvement
at all. I can be called in to and can then hold a two-way conversation. If I
call out over Ekiga/SIP I can hear but can't be heard.

I have eliminated my modem/NAT because I can dial out using S**pe using the same
headset on a different machine. I am considering filing a bug report, but would
like not to have to wait that long for a fix ;-)

Any more suggestions??

Peter

Mark Rijckenberg wrote:
> Your question #62058 on ekiga in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ekiga/+question/62058
>
> Status: Open => Answered
>
> Mark Rijckenberg proposed the following answer:
> Hi,
>
> Please try this solution:
>
> https://answers.launchpad.net/ubuntu/+source/ekiga/+question/1203
>
> Regards,
>
> Mark
>

--

===========================================================
Dr Peter Dzwig

Yannick Defais (sevmek) said : #3

Hi,

You cannot eliminate your Modem/NAT just because Skype does work with it. Skype use all dirty tricks it can to bypass NAT and routers, Ekiga don't do that.

Hi,

Please confirm if you tried the following:

Close all other programs, including music players, video players, Skype, and applets running in the background on the Gnome panel.
After closing all applications, make sure to restart ekiga using the following 2 commands:

killall pulseaudio
ekiga

In ekiga, set all audio devices to "default" and then retest audio.

Regards,

Mark

PeterDz (pdzwig) said : #5

Mark,

...as per your instructions last night. I did it, killed pulse audio and
re-started (not reloaded - I did that earlier) setting all items to default. I
have checked that all i/o devices are set to Default, Plugin remains ALSA, NAT
traversal is STUN with server stun.ekiga.net

Yannick,

Your comment about elimination of NAT/Modem may or may not be true. I only know
that it works. I don't personlly feel justified in making comments about tricks
used by Skype since I don't have the knowledge to say that. I suspect that you
know more than I do about the subject. Can you give me any further information??

Peter

Mark Rijckenberg wrote:
> Your question #62058 on ekiga in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ekiga/+question/62058
>
> Mark Rijckenberg proposed the following answer:
> Hi,
>
> Please confirm if you tried the following:
>
> Close all other programs, including music players, video players, Skype, and applets running in the background on the Gnome panel.
> After closing all applications, make sure to restart ekiga using the following 2 commands:
>
> killall pulseaudio
> ekiga
>
> In ekiga, set all audio devices to "default" and then retest audio.
>
> Regards,
>
> Mark
>

--

===========================================================
Dr Peter Dzwig

Yannick Defais (sevmek) said : #6

Hi PeterDz,

All I'm saying is you better move Skype out of the way if you want to understand the issue with Ekiga. Isn't that reasonable enough? If you want to know more about a proprietary product, you better ask the vendor.

To say it loud and clear: the symptoms described in the report point to a network issue. Thus probably a newer configuration for the router, like explained here: http://wiki.ekiga.org/index.php/Enable_port_forwarding_manually

Best regards,
Yannick

PeterDz (pdzwig) said : #7

Hi Yannick,

What I perhaps didn't make clear was that Skype was running on another machine
that sees the world through the same LAN and modem.

Peter

Yannick Defais wrote:
> Your question #62058 on ekiga in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ekiga/+question/62058
>
> Status: Open => Answered
>
> Yannick Defais proposed the following answer:
> Hi PeterDz,
>
> All I'm saying is you better move Skype out of the way if you want to
> understand the issue with Ekiga. Isn't that reasonable enough? If you
> want to know more about a proprietary product, you better ask the
> vendor.
>
> To say it loud and clear: the symptoms described in the report point to
> a network issue. Thus probably a newer configuration for the router,
> like explained here:
> http://wiki.ekiga.org/index.php/Enable_port_forwarding_manually
>
> Best regards,
> Yannick
>

--

===========================================================
Dr Peter Dzwig

Yannick Defais (sevmek) said : #8

Hi PeterDz,

That was clear. Skype do not use the same network mechanisms as Ekiga do. Ekiga use world wide standards (SIP and H323), Skype use its own closed protocol.

The issue here is internet is not ready yet for automatic NAT traversal. A working group for the internet standards is working on this topic: http://www.ietf.org/html.charters/behave-charter.html

Ekiga follow the standards, thus face this issue. Skype use many workarounds for NAT traversal, one of them is peer-to-peer relay; i.e. some skype clients (ones which are not behind NATs) will route your communication to the contact you want to reach. The SIP protocol can use relay, but it will be based on a central server; this require really big bandwidth from that central server. There is no such server open to the public. There is also a standardisation effort to provide this feature to SIP here: http://www.p2psip.org/

Standards might be long to emerge, they are secure and provide interoperability (one market for VoIP). Skype is a threat for security and split the VoIP market.

Further reading: https://wiki.ubuntu.com/SkypeEthics

Best regards,
Yannick

Can you help with this problem?

Provide an answer of your own, or ask PeterDz for more information if necessary.

To post a message you must log in.