Ekiga set-up; all tests successful; not able to talk

Asked by Laserulo

I have Ekiga set up on my wife's machine and on my laptop. Everything is working. The hardware tests in Configuration Druid work fine on both machines. The <email address hidden> echo works fine on both machines. We can talk to each other using the text chat. We can call each other and accept the call, but when we speak no sound is transmitted either way.
Any ideas.
We are of course testing this in the same room in our house because I want to get this working before I go abroad for a week on Friday. Would that affect things?????

Question information

English Edit question
Ubuntu ekiga Edit question
No assignee Edit question
Solved by:
Yannick Defais
Last query:
Last reply:
Revision history for this message
Yannick Defais (sevmek) said :


Your issue might be this:

    * What is the problem ?

If both clients are located behind the same NAT router (not only the same model, physically the same), clients can't communicate.

    * Why ?

When you are using NAT with STUN, STUN will determine what port on the router will be used to route incoming traffic from the outside to your internal client. That way, when an external client sends a SIP PDU on that port, the PDU will be routed to your internal client by the router.

However, in most cases, a router will not accept to route a packet coming from the inside on the external port and route it back inside, it will only accept to route a packet coming from the outside on the external port.

It has been reported it is what happens with IPCop 1.4.15.

    * What can I do ?

To solve this you may use Avahi: Open the Address Book, people using Ekiga on the LAN should appear in Contacts near me. If there is nothing, try to double-click on Contacts near me.


Best regards,

Revision history for this message
Yannick Defais (sevmek) said :

In short, I think there is a good chance Ekiga can communicate using the SIP address you're using if you go abroad...

Revision history for this message
Laserulo (hugh-reid2) said :

Thanks Yannick,
So far you have provided a partial solution!!! I just tried using Ekiga from my work wifi network (University of the West of Scotland) and was able to hear my wife speaking to me from home .... but she couldn't hear me. I wondered if it could be due to some restrictions placed by the university network: the 500:ekiga.net test worked from my end nevertheless. I also tried with Skype (which I'd rather not use if avoidable) and faced exactly the same problem.
I will try again this evening from my father's house using Ekiga to check whether it is indeed the university network which limits outgoing sound.
I did, of course, check all my hardware and settings and as far as I can see they are fine.

Can I add how impressed I am with how quickly not just you, but others too, have been to respond to questions I have posted. It really does say a lot for the enthusiasm and helpfulness of the Ubuntu community. Congratulations all!

Revision history for this message
Best Yannick Defais (sevmek) said :


Indeed, there is probably some restriction in your university network. Still without a debug output we can't be sure.
cf. http://wiki.ekiga.org/index.php/Debugging_Ekiga#How_to_get_a_debug_output_from_Ekiga

I hope it will work from your father's house.

Best regards,

Revision history for this message
Laserulo (hugh-reid2) said :

Thanks again Yannick,
I was able to successfully talk to my wife at home from my father's house.
The only remaining niggle was that I couldn't call her; she had to call me. I haven't got round to doing the debug output, but when I do that it may reveal why I can't initiate the call.
I must add that before going to my father's I went through the Configuration Druid on both machines and set them to enable STUN support. That didn't make any improvement in my own house, so I'm not sure if it would have been a problem in my father's if I hadn't enabled it.
Anyway, your help much appreciated.

Revision history for this message
anil k prasad (akprasad450) said :

that ekiga phone doesn't work,sound is awfull.i can't talk.other side of phone can't hear me.also get disconnected
i tried all the configurations and stuff.nothing worked.