Two-second delay on answering

Asked by C Filorux on 2008-07-14

I have ekiga hooked up to the local asterisk exchange (user 123@192.168.0.99 or similar), and also to an ekiga.net account. When I get an incoming phone call, the answer box pops up immediately, but there is a delay of over 2 seconds from when I click "Answer" to when the voice stream is actually connected. (Hello, hello, hello, ... hello ... oh, hello).

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ekiga Edit question
Assignee:
No assignee Edit question
Last query:
2008-07-14
Last reply:
2009-08-07
C Filorux (breakfast) said : #1

Before someone asks - it's ekiga 2.0.12-0ubuntu2 (packaged with Ubutu Hardy i386).

Yannick Defais (sevmek) said : #2

Hello,

The next version of Ubuntu (8.10) will contain Ekiga 3.0. Would you be king enough to test the development version of ekiga (2.9) to check if this problem is still there?
Packages and instructions are here: http://snapshots.ekiga.net/

Best regards,
Yannick

pjw (pjw1965) said : #3

Still the same in Jaunty with ekiga 3.2.

Regards

Peter

sentienc3 (trevor-hopps) said : #4

I've just checked with ekiga version 3.2 connected to both an asterisk server and Trixbox.
I can confirm there is a 2 second delay using the standard codec/config settings.
If however you change the codec from alaw/ulaw to gsm and change your extension
config file to comply with gsm the delay is eliminated completely with good voice quality.
It would seem to be codec related. I have not tried any other codecs other than
those indicated above.

Trevor

Yannick Defais (sevmek) said : #5

sentienc3,

The codec indeed can make a difference, as some do have resilience to packet lost, other do not not. AFAIK it is what you can expect from GSM compared to PCM.

Is the call using internet, or is your setup inside a LAN? Because inside a LAN it should not be packets lost.

Beside, it will help understand if you could provide a debug ouput for both cases (PCM and GSM) using this command:
$ ekiga -d 4 2>output.txt

It might be some interoperability issue (i doubt it...).

A workaround could be to have a smarter selection order of codecs in ekiga preferences...

Best regards,
Yannick

Can you help with this problem?

Provide an answer of your own, or ask C Filorux for more information if necessary.

To post a message you must log in.