why am I always at stanby ?

Asked by Mihail Fontul on 2006-07-15

I can't call anyone with ekiga. I used druid to configure the system, everything it's ok, but once start calling a number, I always get this error message:

''Could not open audio channel for audio reception

An error occured while trying to play audio to the soundcard for the audio reception. Please check that your soundcard is not busy and that your driver supports full-duplex.
The audio reception has been disabled.''

For sure it's not a souncard problem, skype it's working properly. Please help me.

Mihail

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ekiga Edit question
Assignee:
No assignee Edit question
Last query:
2006-07-15
Last reply:
2008-10-16
Onkar Shinde (onkarshinde) said : #1

Since you are not facing the problem anymore, can you please close this support request?

Can you try going into your preferences (Edit > Preferences), Audio Devices and changing the devices to "default" instead of the name of the device?

Xavier Bassery (xaba) said : #3

I am not the original poster, but I can testified that your workaround has worked for me.

In the "Preferences > Devices > Audio Devices" screen, I replaced "Ensoniq AudioPCI" with "Default" only for "Output device".
Doing so I did not get any longer the "An error occured while trying to play audio to the soundcard for the audio reception" message.

Linda Vale (linda-e-vale) said : #4

I realize this thread is from 2006, but I am new to Ekiga (2 weeks) in Linux Ubuntu and I am getting the same error message as noted in Mihail Fontul. I have followed the limited directions posted and nothing has changed. Still the same error. Soooooo frustrating!!! Is there some one who can help me rectify this issue?????

Yannick Defais (sevmek) said : #5

Hello,

There is 3 places to setup audio devices in Ekiga preferences. Can you try to set them all to "Default"?

Go to the menu Edition → Preferences → Devices → Audio Devices

    * Select "ALSA" as the audio plugin
    * Select "Default" as output
    * Select "Default" as input

Then go to the menu Edition → Preferences → General → Sound Events

    * Select "Default" as alternate device output

If this doesn't work, can you tell me what version of Ubuntu you are using?

Best regards,
Yannick

Linda Vale (linda-e-vale) said : #6

Hi Yannick, Everything is set as you detailed. Still not working. Apparently the other party (the number I'm dialing) gets the call, but there is no sound on my end, just the error message as listed.
I'm using the latest version of Ubuntu 8.04 LTS 64bit.

I'm wondering if anything needs to be adjusted/changed in the sound control panel/volume control?

Yannick Defais (sevmek) said : #7

Hello,

''Could not open audio channel for audio reception" means another program is grabing the sound card and forbid ekiga to access it.

With 8.04 a new sound server has been introduced: pulse audio. It normally should deal with software and enable them to use the sound card, even at the same time.

For some unknow reason it fails for your system.

Let's try to disable pulse audio, it ekiga works without it, it means there is an issue either in ekiga, or in pulse audio.

Exit Ekiga.
Open a terminal, type:
"pasuspender -- ekiga"
(without quotes)

This should start ekiga and suspend pulse audio. If it works then we will be able to fill a bug against ekiga or pulse audio.

Best regards,
Yannick

Linda Vale (linda-e-vale) said : #8

Hi Yannick,

I entered the command as you detailed and the "command cannot be found".

Here's another twist to the Ekiga issue: I set up Ekiga on the second user account on my laptop. Entered all fields as required; Entered a phone number; The same error message in question popped up BUT the call went thru!!!!!!!

Waiting for your next post. Thanks for your assistance.

Kind Regards,

Linda

Linda Vale (linda-e-vale) said : #9

I'm still having the same issue as previously posted. I decided to try my own resolve to this issue by adding another user to my laptop and starting Ekiga "fresh". I have entered all data correctly and now Ekiga tells me that voipdiscount.com Registration failed.

Please, I am in dire need of making calls to the exterior with the use of my voipdisount.com account. I need some resolve to this issue.

alinuxfan (agjennings) said : #10

I was able to get ekiga working by:

quitting ekiga
opening a terminal to type:
$killall pulseaudio

then opening back up ekiga with all devices being set to default. I hope this helps until we can figure out how to make ekiga and pulseaudio play nicely together

Adam

Can you help with this problem?

Provide an answer of your own, or ask Mihail Fontul for more information if necessary.

To post a message you must log in.