Can not install libc6-dev

Asked by Russell Sutherland on 2012-12-12

When I try to install libc6-dev the following error occurs:

# apt-get install libc6-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 libc6-dev : Depends: libc6 (= 2.15-0ubuntu10.2) but 2.15-0ubuntu10.3 is to be installed
E: Unable to correct problems, you have held broken packages.

This prevents me from developing software on my ubuntu server distribution.
I am running:

# uname -a
Linux dhcp-7 3.2.0-34-generic #53-Ubuntu SMP Thu Nov 15 10:48:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

On a 64bit system kernel. I am running precise:

Here is my sources.list:

deb http://mirror.eis.utoronto.ca/ubuntu/ precise main restricted
deb-src http://mirror.eis.utoronto.ca/ubuntu/ precise main restricted

deb http://mirror.eis.utoronto.ca/ubuntu/ precise-updates main restricted
deb-src http://mirror.eis.utoronto.ca/ubuntu/ precise-updates main restricted

deb http://mirror.eis.utoronto.ca/ubuntu/ precise universe
deb-src http://mirror.eis.utoronto.ca/ubuntu/ precise universe
deb http://mirror.eis.utoronto.ca/ubuntu/ precise-updates universe
deb-src http://mirror.eis.utoronto.ca/ubuntu/ precise-updates universe

deb http://mirror.eis.utoronto.ca/ubuntu/ precise multiverse
deb-src http://mirror.eis.utoronto.ca/ubuntu/ precise multiverse
deb http://mirror.eis.utoronto.ca/ubuntu/ precise-updates multiverse
deb-src http://mirror.eis.utoronto.ca/ubuntu/ precise-updates multiverse

deb http://mirror.eis.utoronto.ca/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://mirror.eis.utoronto.ca/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu eglibc Edit question
Assignee:
No assignee Edit question
Last query:
2012-12-12
Last reply:
2012-12-12

I suggest you comment out the backport lines, they can cause issues

Russell Sutherland (russ) said : #2

Nope... I commented out the backport entries, performed:

# aptitude update && aptitude upgrade

The problem persists.

Run:

sudo -i
echo "libc6-dev hold" | dpkg --set-selections; apt-get -f install
exit

Can you help with this problem?

Provide an answer of your own, or ask Russell Sutherland for more information if necessary.

To post a message you must log in.