libc6 (>= 2.13-5) needed when installing multiarch-support

Asked by manyi on 2011-12-29

Hi! I am using Ubuntu 10.04 LTS - the Lucid Lynx - released in April 2010. I try to install multiarch-support
> dpkg -i multiarch-support_2.13-24_i386.deb

and get

Selecting previously deselected package multiarch-support.
(Reading database ... 352650 files and directories currently installed.)
Unpacking multiarch-support (from multiarch-support_2.13-24_i386.deb) ...
dpkg: dependency problems prevent configuration of multiarch-support:
 multiarch-support depends on libc6 (>= 2.13-5); however:
  Version of libc6 on system is 2.11.1-0ubuntu7.8.
dpkg: error processing multiarch-support (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 multiarch-support

Then I look for libc6 in Synaptic Package Manager. Both the installed version and the latest version are 2.11.1-0ubuntu7.8, even after 'Reload'.

I found http://packages.debian.org/wheezy/i386/libc6-dev/download . As I am using the LTS, I wonder whether it is a good idea to upgrade to this testing version (as stated here: http://packages.debian.org/search?keywords=libc6)? Any comment?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu eglibc Edit question
Assignee:
No assignee Edit question
Last query:
2011-12-29
Last reply:
2012-09-21

Mixing debian debs into ubuntu is not advised nor supported. You will get a huge mess.

mycae (mycae) said : #2

Why not just run debian, if you need such? I would recommend creating a VM with debian on it, so you don't even have to reboot to go between the two. As actionparsnip says, the libraries are fundamentally incompatible, and you should almost *never* manually install a deb, or mix sources that are not guaranteed to be built in sync.

Just because something is in a .deb, does not mean that it will work with every deb based system -- a deb is roughly a fancy zip file, with some dependency information tagged on it, and a few install/uninstall scripts and manifests.

bhs (bharath-vegito) said : #3

The package multiarch-support_2.13-24_i386.deb must have been for natty or oneric. Libc6 version is fixed for a given distro.
You need to get 11.04 or 11.10 to get this package installed.

Can you help with this problem?

Provide an answer of your own, or ask manyi for more information if necessary.

To post a message you must log in.