Dependency issues wrt libc6/libc6-i386

Asked by aslam karachiwala on 2011-11-01

System: Ubuntu 11.10 amd64 (fresh install)

As reported in Bug #881223, I ran into the following issue when trying to install lsb:
===
$ sudo apt-get -f install libc6-i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-i386 : Depends: libc6 (= 2.13-9ubuntu3) but 2.13-20ubuntu5 is to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get -f install lib32z1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lib32z1 : Depends: libc6-i386 (>= 2.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
===

Is this a bug in eglibc?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu eglibc Edit question
Assignee:
No assignee Edit question
Solved by:
aslam karachiwala
Solved:
2011-11-07
Last query:
2011-11-07
Last reply:
aslam karachiwala (akwala) said : #1

Not a bug. I was using a mirror server w/ outdated repos.