Failing to install Esset Anti virus ( dependency problems - leaving unconfigured)

Asked by inno_k on 2011-08-04

root@xxxx:/nod32# file /usr/bin/file
/usr/bin/file: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, stripped

root@xxxx:/nod32# dpkg -i esets-3.0.20.amd64.deb
(Reading database ... 50225 files and directories currently installed.)
Preparing to replace esets 3.0.20 (using esets-3.0.20.amd64.deb) ...
Unpacking replacement esets ...
dpkg: dependency problems prevent configuration of esets:
esets depends on libc6-i386 | libc6-i686; however:
Package libc6-i386 is not installed.
Package libc6-i686 is not installed.
dpkg: error processing esets (--install):
dependency problems - leaving unconfigured
Processing triggers for ureadahead ...
Processing triggers for man-db ...
Errors were encountered while processing:
esets

How do i solve that problem

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu eglibc Edit question
Assignee:
No assignee Edit question
Solved by:
Eliah Kagan
Solved:
2011-08-04
Last query:
2011-08-04
Last reply:
2011-08-04

Install the package called libc6-i386, then try installing esets again:

sudo apt-get update
sudo apt-get install libc6-i386
sudo dpkg -i esets-3.0.20.amd64.deb

(If you have a root terminal, with # instead of ~, then you can leave sudo off the beginning of these commands.)

inno_k (kurehwai) said : #2

Thanks Eliah Kagan, that solved my question.