efax- Warning: /dev/ttyS0 locked or busy - waiting

Asked by John Hagerman on 2009-11-27

Ubuntu 9.10 AMD64, USR 3CP5610 internal modem I have been using since Windows 95, and which worked fine in Ubuntu 9.04 AMD64 as a fax modem with a converted-to-Debian-with-alien Red Hat Linux driver from 3Com, now gives me this message when I try to put efax in Standby mode:

"Warning: /dev/ttyS0 locked or busy - waiting"

Efax will not operate with ttyS1, 2 or 3. Ubuntu 9.10 apparently has something new which is loading at boot and takes over ttyS0, preventing efax accessing it. I need that fax machine!

My questions are - what is it - and can I disable it?

Jack

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu efax Edit question
Assignee:
No assignee Edit question
Last query:
2009-12-06
Last reply:
2009-12-07
Larry Jordan (larryjor) said : #1

     I stuck with 9.04, and now have an HP printer with built-in fax that seems to work, but used to use an external fax modem with efax. From what I remember it creates a "lock file" (dummy file that just tells the system the device is already in use). I don't have efax anymore, so can't look at the man page to check on it (type 'man efax' in a terminal and read), but think it can safely be "removed" and reset to accommodate your needs based on info in the efax or associated man pages. Sorry, but that is all I can offer for help, but think this will get you back in the right direction.

John Hagerman (handj949) said : #2

marcobra (Marco Braida) wrote:
> Your question #91914 on efax in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/efax/+question/91914
>
> Project: Ubuntu => efax in ubuntu
>
>
Could you be a little less concise and a little more informative?

Larry Jordan (larryjor) said : #3

     Sigh. Really didn't want to reinstall efax, but okay. According the to manual on efax (man efax) there should be a lock file that keeps 2 different programs from trying to use the modem at the same time. It will look like a plain old file, probably in the /var/lock directory, and name will refer to the modem in some way. File name will also include something like 'lck' (lock), so may look like 'lck.modem' when you look in the directory. Removing this file will allow access to the modem for faxes again. The man page also says that if you want to set it up to receive faxes whenever they come in, without blocking the modem from use by other programs, use the -s option.

John Hagerman (handj949) said : #4

I'm sorry you went to the trouble of reinstalling efax because, if you're still using 9.04, efax worked fine for me in 9.04 - this problem arrived with the update to 9.10.
The only thing I have in /var/lock is firestarter, and I doubt it is using a serial port.
Checking for files containing 'lock' gives me a whole collection, most of which are executables, but no mention of 'modem'.
It has to be something which uses ttyS0 and precedes efax during boot. How's that for a wide selection!

Jack

Christian Baedorf (cbaedorf) said : #5

i had the same problem and it worked for me to deinstall the "modem-manager" package via synaptic. now efax works fine.

John Hagerman (handj949) said : #6

Christian Baedorf wrote:
> Your question #91914 on efax in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/efax/+question/91914
>
> Christian Baedorf posted a new comment:
> i had the same problem and it worked for me to deinstall the "modem-
> manager" package via synaptic. now efax works fine.
>
>
Thanks!
I'll take a run at that as soon as I get my boot problem fixed. (Boot
problem indirectly caused by trying to fix efax problem. Talk about
going from bad to worse!)

Jack

John Hagerman (handj949) said : #7

John Hagerman wrote:
> Your question #91914 on efax in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/efax/+question/91914
>
> You gave more information on the question:
> Christian Baedorf wrote:
>
>> Your question #91914 on efax in ubuntu changed:
>> https://answers.launchpad.net/ubuntu/+source/efax/+question/91914
>>
>> Christian Baedorf posted a new comment:
>> i had the same problem and it worked for me to deinstall the "modem-
>> manager" package via synaptic. now efax works fine.
>>
>>
>>
> Thanks!
> I'll take a run at that as soon as I get my boot problem fixed. (Boot
> problem indirectly caused by trying to fix efax problem. Talk about
> going from bad to worse!)
>
> Jack
>
>
Got my boot problem solved, removed ModemManager (I had been looking for
modem-manager) and.....Problem solved!
I'll file a bug on ModemManager.
Thank you very much, Christian!

Jack

The same problem. I have removed ModemManager and still persist. The problem might be the file /var/lock/LCK.ttyS1 When I remove it, KdeprintFax creates it again if I try to send a fax.

Can you help with this problem?

Provide an answer of your own, or ask John Hagerman for more information if necessary.

To post a message you must log in.