How to use the eeepc-acpi-source package?

Asked by Typhoe on 2008-02-28

Hi,

can you explain or indicate a "how to" to use this package?

thank you

Typhoe

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu eeepc-acpi Edit question
Assignee:
No assignee Edit question
Solved by:
Typhoe
Solved:
2008-02-29
Last query:
2008-02-29
Last reply:
2008-02-29

Nohow -- this is "system thing" -- just install it and system will use it...

Typhoe (spamistrash) said : #2

Well,

that's what I thought... but it does'nt seem.

In the deb, the files included are:
./
usr/
usr/share/
usr/share/doc/
usr/share/doc/eeepc-acpi-source/
usr/share/doc/eeepc-acpi-source/copyright
usr/share/doc/eeepc-acpi-source/changelog.Debian.gz
usr/src/
usr/src/eeepc-acpi.tar.bz2

So there does not seem to be any module directly in the deb.

The last file "eeepc-acpi.tar.bz2" contains something to create the module for the eeepc I think.
But how can I use it exactly?

thank you

Albert Damen (albrt) said : #3

You can build the module with the module-assistant program.
First install the package eeepc-acpi-source, this will automatically install module-assistant if needed:
$ sudo apt-get install eeepc-acpi-source

Then build the new package (-u ~ creates it in your home directory):
$ module-assistant build eeepc-acpi-source -u ~

Then install the package you have built:
$ sudo dpkg -i ~/eeepc-acpi-modules-2.6.24-10-generic_1.0-1+2.6.24-10.16_all.deb

(the exact package name may be different, depending on your system)

You may have to install the kernel headers first (probably linux-headers-generic, but this also depends on the system you are using, I am not familiar with the eeepc yet).

Typhoe (spamistrash) said : #4

Thank you.

So that's pretty much what I actually found (on the debian eeepc wiki : http://wiki.debian.org/DebianEeePC/HowTo/Install?highlight=%28%28DebianEeePC%7CHowTo%7CCustomInstaller%29%29#head-ac3cbe1a51a92b3ed29b3a9e55a34f9d6c70e271 ).
m-a a-i eeepc-acpi
modprobe eeepc_acpi
/etc/init.d/acpid restart

But now, I have an other problem...

module-assistant does'nt find the kernel headers although I HAVE them...
uname -r gives me : 2.6.24-10-generic
I have tried "sudo m-a prepare" and it says I already have the linux-headers-2.6.24-10-generic and build-essential installed. So that should be ok.

But when I launch "m-a build eeepc-acpi-source -u ~" , I get a Dialog screen telling me that no kernel header is found (and it indicates to install the linux-headers-2.6.24-10-generic)

So I really don't understand.... Is it a bug in m-a ?

Albert Damen (albrt) said : #5

I don't know why that does not work, as it works fine here.

You can try to explicitly specify the location of the kernel headers like this:

$ module-assistant eepci-acpi-source -u ~ -k /usr/src/linux-headers-2.6.24-10-generic

If that fails as well, you can also try to build the package in the standard location, but then you need to use sudo:

$ sudo module-assistant eepci-acpi-source
In this case the package will be placed in /usr/src

Typhoe (spamistrash) said : #6

> I don't know why that does not work, as it works fine here.
Well, I really don't know too... :'(

> You can try to explicitly specify the location of the kernel headers like this:
> $ module-assistant eepci-acpi-source -u ~ -k /usr/src/linux-headers-2.6.24-10-generic
Already tried that... no improvement at all... It keeps saying that the kernel headers are not installed!

The only thing I manage to do is to "make" the module manually without error:
cp /usr/src/eeepc-acpi.tar.bz2 ~
tar jxvf eeepc-acpi.tar.bz2
cd modules/eeepc-acpi/
make

I get two new files (eeepc_acpi.mod.o and eeepc_acpi.ko)

But I don't know how to use (/ where to put) them...
(and sudo make install doesn't work!)

Typhoe (spamistrash) said : #7

Whaou!!!!

I really don't know how (and why!), but I managed to do it.

I was in the modules/eeepc-acpi/ directory I previously created, and tried again the command:
sudo module-assistant build -k /usr/src/linux-headers-2.6.24-10-generic eeepc-acpi-source -u ~

and it eventually worked this time!
I get a .deb file (eeepc-acpi-modules-2.6.24.2_1.0-1_all.deb) in my $HOME

But I still have a problem...

The compiled deb seems to be for a 2.6.24-2 kernel... ??? I don't understand why.

But looking in the deb, I found where the module should go (/lib/module/$(uname -r)/misc/eeepc_acpi.ko so I tried to do it manually too, but then "sudo modprobe eeepc_acpi" gives me "Fatal: Module eeepc_acpi not found." error

So I'm still stuck...

Albert Damen (albrt) said : #8

After you copy the module to lib/module/.... you must run the command sudo depmod -a.
However, the version number you get indeed suggests you built the module for the wrong kernel.
You could just try to re-install the kernel headers with sudo apt-get install linux-headers-2.6.24-10-generic and see if that helps.

Typhoe (spamistrash) said : #9

Thank you!

depmod -a indeed solved my problem.

The module is now seen but as you say, it seems to be build for the wrong kernel version:
vermagic: 2.6.24.2 SMP mod_unload 586

That's really strange as I only have the 2.6.24-10 kernel headers on my eeepc...

I'll try to reinstall from a fresher hardy build (although I'm up to date on my system) to see if it solves te problem.

anyway, thank you very much for your help!

Let say the problem is (should be !) solved.

Richard B. (richie) said : #10

Hello!

But the module doesn't work for me!! It builds a .deb and loaded correctly, but the addition keys still doesn't work...

Whats wrong?