Access Denied to eCryptfs folder

Asked by sean auth on 2019-07-19

I have utterly clogged up my HDD on my laptop, with the /home/user folder being the culprit. The PC, too bloated to boot up or shut down, has been booted from a live USB. I have subsequently booted to a live install usb and was unsuccessful in my attempt to mount ecryptfs following the livecd recovery guide. (https://help.ubuntu.com/community/EncryptedPrivateDirectory#Long_way), I got the following error: error mounting ecryptfs: [-2] No such file or directory. Googling the error message that appeared in the syslog, I saw that the guide was specifiying the simulink, not the actual path to the encrypted directory. Upon execution of sudo mount -t ecryptfs /media/xubuntu/1771....b56/home/.ecryptfs/user/.Private /home/user/Private the terminal replied mounted ecryptfs.

Thinking the saga over, I try to open /home/user/Private and find that my permission is denied!
The data's all in there, all 300 gigs of whatever it may be; but the owner is 1000 and nobody but the owner has access to it. How do I fix this? I'm so close!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ecryptfs-utils Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-07-19
Last query:
2019-07-19
Last reply:
2019-07-19
Best Manfred Hampl (m-hampl) said : #1

I have never tried this myself, but according to documentation you should be able to start a file explorer program with the rights of your provious user with the following command (to be executed in a terminal window):

sudo --user=\#1000 nautilus

sean auth (sauth) said : #2

Thanks Manfred Hampl, that solved my question.