Problem installing a Private Folder

Asked by n2nd on 2009-02-04

I installed a Private folder following the instructions in the Wiki, but the readme and icon to access saved data were not present. I then attempted to set up the links manually as detailed under "Use in conjunction with Auto-login", which produced a message that the objects did not exist. Finally, I attempted to remove the Private folder, again following the Wiki. Everything worked, except that Private could not be deleted because it was in use. I entered the command-line strings by cutting and pasting from the Wiki, so I don't think there were typos.

I would like either to install a working Private folder or to delete the non-working one.

I am using 8.10 on a Dell Mini 9, with 2 Gbytes of RAM and 32 GBytes of solid-state disk, with 19 GBytes free. The installation is standard, except that /tmp is mounted on a ramdisk and there is no swap.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ecryptfs-utils Edit question
Assignee:
No assignee Edit question
Solved by:
n2nd
Solved:
2009-02-05
Last query:
2009-02-05
Last reply:
2009-02-05
db429 (db429) said : #1

Pls tell us which instructions? These? https://help.ubuntu.com/community/EncryptedPrivateDirectory

Did u log out and log in again as mentioned in step 4?

did i understand u right, that u use autologin for your dellmini9?
when u say
>Everything worked, except that Private could not be deleted because it was in use.
it means that following command:
ecryptfs-umount-private
at least didn't work either.

what version of ecryptfs did u use?

Tom (tom6) said : #2

Is this a standard Wubi install? When you boot up do you get the Windows splash screen and moving bar followed byt the dual-boot menu or does "Grub 1.5" flash up just before the dual-boot menu?

Good luck with this
Regards from
Tom :)

n2nd (n2nd) said : #3

DieB,

Yes, I used the instructions you referenced.

 I do not use autologin, and I tried the manual link insertion procedure listed in that section only because after the standard install, my Private folder was empty. I did log out and back in after making the links. When that didn't work, I completely shut down and restarted. I then tried to uninstall ecryptfs (using the command-line procedure given in the Wiki), which is when I found that I could not remove the Private folder.

 I installed ecryptfs for the first time yesterday (February 4) using Synaptic (version 53-1ubuntu12).

Tom,

The Mini 9 was delivered with Dell's modified Ubuntu 8.04 as its only operating system. I did a clean install of 8.10 from a USB memory stick created from the 8.10 Live CD.

Because there is only one OS, I don't see the GRUB menu on boot-up.

By the way, the disk has two partitions - a very small FAT one with (I think Dell's recovery software) and one of about 32 GBytes with the Linux file system.

Thank you both for your help.

n2nd (n2nd) said : #4

I found the problem - there is a conflict between sbackup and ecryptfs. The reason I could not remove the Private folder was that it apparently was being monitored by sbackup. Once I changed sbackup's configuration to "Manual Backups Only", I was able to delete Private by following the instructions in the Wiki under "How to Remove an Encrypted Private Directory Setup".

Since regular backups are more important to me than having a Private folder, I'll leave sbackup in place and use gpg to encrypt any sensitive files.

n2nd (n2nd) said : #5

After my last post, I did some more testing, and I no longer think that sbackup is the problem. I set sbackup to do manual backups only and tried again to install ecryptfs, with the same result as before. The Private folder is empty, and if I create a file in it, I see nothing there. I then uninstalled ecryptfs with the same result as when sbackup was set to do scheduled backups; that is, I could not delete the Private folder because it was in use by another program. However, when I logged out and back in, I was able to delete Private. Clearly, ecryptfs is not compatible with something in my setup. Since, I need to do backups and can use gpg to encrypt files, my solution is the same - I won't use ecryptfs.