The program 'Eclipse' received an X Window System error.

Asked by Akshat Saha on 2012-03-28

Hi,

I am not able to run Eclipse on my 64-bit Ubuntu 10.10 machine. This is error log:

ERROR:
$ eclipse

progname=.; RGBA=on
The program 'Eclipse' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 8113 error_code 8 request_code 149 minor_code 4)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I tried to google it, and updated my xul-runner cleaned the dot(.) directory in root.
But nothing seems to work.

I get the same problem when I launch Android AVD Manager.

Can anyone help me with this?

Thanks in advance

Akshat :)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu eclipse Edit question
Assignee:
No assignee Edit question
Last query:
2012-03-28
Last reply:
2012-03-28

If you make a fresh user, is it ok there?

Akshat Saha (akshat-embedded) said : #2

I tried to run in root, and it was working fine... I think, this might be some X related configuration issue. But can't get to the root of it.

root has a lot more access than your user, make a fresh user and see if it's the same

Akshat Saha (akshat-embedded) said : #4

I made a new simple user and tried running eclipse through terminal.
Same error.

Sounds like a bug with permissions. You should report it.
You may be able to get around the bug with:

gksudo eclipse

HTH

Akshat Saha (akshat-embedded) said : #6

Yes, as I already told works fine in root or with sudo permissions.

But I don't want root permissions.

Filed the but here : https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/966888

Can you help with this problem?

Provide an answer of your own, or ask Akshat Saha for more information if necessary.

To post a message you must log in.