Where are the results of the initial file system check?

Asked by Uwe Geuder on 2009-02-13

My Hardy Heron 8.10 started to behave pretty weird, so I decided to run a file system check at boot up (I have only one hard drive). Google found that this can be done by creating file /forcefsck (sudo touch /forcefsck)

The file system check was running on the splash screen and I did something else. When I came back the splash screen was gone. Now I would like to know whether fsck has found anything, which it has corrected (mainly for curiousity)

I searched /var/log/* for fsck and e2fs, but didn't see anything interesting.

Aren't the results logged anywhere?

Yes, when search for the answer I found a better way to do it. Boot from a LiveCD and invoke fsck manually on the command line. Then you should be able to see the output and you can check the exit status (documented on the man page). But I don't expect that a 2nd fsck run just an hour after the 1st one will produce any interesting info.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu e2fsprogs Edit question
Assignee:
No assignee Edit question
Solved by:
Alan Jenkins
Solved:
2009-02-14
Last query:
2009-02-14
Last reply:
2009-02-13
Best Alan Jenkins (aj504) said : #1

The initscripts (/etc/init.d/check*) mention /var/log/fsck.

Uwe Geuder (ubuntulp-ugeuder) said : #2

Thanks Alan Jenkins, that solved my question.

Uwe Geuder (ubuntulp-ugeuder) said : #3

Thanks Alan, that helped. /var/log/fsck is a directory, that's why grepping /var/log/* did not produce any results.

/var/log/fsck contains 2 files from the the time when I booted with the fsck enabled.

I thought I had grepped the whole /etc/init.d/* for fsck and got 0 hits, but obviously I hadn't. Maybe some typo or some other stupid user error...