Please update this package. Newer version is 2013.60 for now.

Asked by Alif M. Ahmad on 2013-11-12

I searched for a lighweight ssh2 client and server. Finally I found that dropbear meet the qualification.
I've installed dropbear from Ubuntu repository. Dropbear was installed fine, but it lacked a lot of things, such as dropbearconvert to do conversion between OpenSSH private keys to dropbear ones.

I was so surprised that Debian and its derivative, such as Ubuntu has outdated dropbear in package-repository. The newest version is 2013.60, while the latest version in Ubuntu package is 2012.55. So I decided to compile dropbear from source to get the most up-to-date dropbear.

While some users are able to compile and install from source, it's more convenient to use the Ubuntu package manager to install this app. Simple and efficient for most newbies, like me.

Would any of Ubuntu/Debian developer update this package? And please include dropbearconvert in this package in addition to the existing dbclient, dropbear, and drobpearkey.

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu dropbear Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2013-11-17
Last query:
2013-11-17
Last reply:
2013-11-12

I suggest you report a bug. There may be a PPA with the newer version here on Launchpad

Best Manfred Hampl (m-hampl) said : #2

Ubuntu takes over most packages from Debian (and as far as I can see this includes dropbear).
There is already a bug report in Debian for requesting that update http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=727214 but that has not yet been completed (just the update from 2012.55-1.3 to 2012.55-1.4 was done in testing and unstable).
When Debian upgrade their version to the current release, Ubuntu will then follow.

Alif M. Ahmad (alivema4ever) said : #3

Thanks Manfred Hampl, that solved my question.