Ubuntu

droidbattles -textmode either fails or no output

Asked by Keith Worrell on 2009-02-05

Any use of droidbattles -textmode options either produces no output or produces an error. loading config files or checking them results in format error, and -assemble for .basm files always produces "could not open file" using absolute or relative paths. I love this game, but I would really like to be able to run my own automated simulations from the command line. Repo also has version 1.0.6-6 while current version is 1.0.7; I could not seem to get the source to compile properly though.

I tried all the examples @ http://www.bluefire.nu/droidbattles/index-7.html#ss7.7 changing the paths to match my machine, and using droids on the website. same problem with all.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu droidbattles Edit question
Assignee:
No assignee Edit question
Solved by:
Keith Worrell
Solved:
2009-02-08
Last query:
2009-02-08
Last reply:
2009-02-07
Tom (tom6) said : #1

I'm sorry i haven't a clue about this one and it seems like no-one else has either. All i can suggest is posting this as a bug-report (usually click on Help in the game and then click on "Report a bug/problem". Also it might be worth trying to look around the forums on the main Ubuntu site (rather than Launchpad) and maybe try BugZilla and even google has been amazingly good.

If you do find an answer from elsewhere please let us know in here because Ubuntu and linux generally really needs to work hard at getting games working decently.

Good luck and regards from
Tom :)

Tom (tom6) said : #2

If you are still having trouble with this then please post it as a new question. Only the most recent questions tend to get looked at so posting/reposting a question just before america arrives online gives the best chance of getting a good few answers.

If the problem has been resolved then please follow the link to the forum thread and mark it as Solved.

Good luck and many regards from
Tom :)

Keith Worrell (keith-penguin) said : #3

Filed a bug report.

Keith Worrell (keith-penguin) said : #4

err... guess don't need to reopen the question here. sorry.