dpkg 1.14.21

Asked by N838901 on 2009-02-02

When will dpkg in Intrepid be updated to >1.14.21 ?

This is needed to fix this bug:

dpkg: ../../src/packages.c:221: process_queue: Assertion `dependtry <= 4' failed

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu dpkg Edit question
Assignee:
No assignee Edit question
Last query:
2009-02-07
Last reply:
2009-10-31

dpkg will more than likely just get security updates for it's current version but the version in Jaunty will be 1.14.24. If your experiencing a bug in Intrepid's version of dpkg the best place to start for getting it patched would be to file a bug report. Also, I'm not certain about how dpkg does it's version naming but usually if it ends in an odd number than it's an unstable release. Hope this info helps

N838901 (nblanton) said : #2

Well, there have been quite a few bugs reported already on this issue, and I have read through the bug reports and it seems that version 1.14.21 and later fix this issue. Any chance at backporting the version from Jaunty into Intrepid?
Also, do the ISO images get rebuilt on occasion to include these updates? Thanks for your help.

It has dependencies that are only included in Jaunty so I'm not sure a backport will be available. Are you trying to build dpkg from source? It looks like it from the original question that's why I ask.

N838901 (nblanton) said : #4

Sorry for the delay in replying. I am not trying to build dpkg from source. I had searched the net for the error message above and had come across numerous other occurrences of this bug. The only solution I have found thus far is that any version later than 1.14.21 fixes it. The earlier version of dpkg in 8.04 doesn't include this bug.

Robb Munson (r.munson) said : #5

To answer the question about "ISO images getting rebuilt"...sometimes yes, as was the case of our LTS release of 8.04 (It has 3 revisions to it). 8.10 and on I am not sure about.

Can you help with this problem?

Provide an answer of your own, or ask N838901 for more information if necessary.

To post a message you must log in.