dpkg was interrupted

Asked by Drew Meigs on 2008-11-18

I just installed 8.04 on my desktop computer this morning. While retrieving the initial updates, I got the following message:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E:_cache->open() failed, please report.

I read through some of the bugs as well as some of the questions asked, but could not find any reports that matched my situation beyond this point. I ran the command it told me to using sudo in the terminal and received the following message:

gzip: stdout: No space left on device
update-initramfs: failed for /boot/initrd.img-2.6.24-21-generic
dpkg: subprocess post-installation script returned error exit status 1

I can typically hold my own ground in Ubuntu, but I am still learning what things mean. I attempted to boot into recovery mode as someone has recommended and got the exact same message. i believe someone also recommended to use the command 'sudo apt-get install -t'. i wasn't sure what that command was supposed to accomplish, but it simply restated the problem I referenced above. Can anyone help me? It would be greatly appreciated. This computer is not new by any means, but it is still certainly good enough (as far as I know) to successfully run Ubuntu. Thank you for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu dpkg Edit question
Assignee:
No assignee Edit question
Solved by:
Drew Meigs
Solved:
Last query:
Last reply:
Revision history for this message
Michael Glauche (michael-glauche) said :
#1

Do you have a seperate boot partition ? Does it have enough free space ?
To check run "df" from a console, look for a /boot partition and see if it has enough space.

Revision history for this message
Drew Meigs (drewmeigs) said :
#2

Actually, I believe that might be the problem. However, when I try installing a package to help me resize the partition, it gives me the same error, not letting me do anything. I heard someone say a boot partition could be 50MB and be sufficient, so that is what I did. Is there another way to solve this problem? Thanks!

Revision history for this message
Drew Meigs (drewmeigs) said :
#3

I suppose another question would be: how big is the /boot partition supposed to be in order to decrease the likelihood of encountering problems like this?

Revision history for this message
Drew Meigs (drewmeigs) said :
#4

Hey, guys. I apologize for all the updates. I was thinking, my problem with resizing this partition is that it has to be small (in the ballpark of the 50MB i have it) because of the BIOS. When I attempt to install Ubuntu as my only OS, I originally tried to use automatic partitioning in the installer. That didn't work and gave me a GRUB Error either 8 or 18, don't remember. I did some research and it said my BIOS didn't support the size of my hard drive. So everyone recommended I put my /boot partition around 50MB. When I did that, the problem mentioned in this question occurred. So I resized/reimaged and put my /boot partition at 250MB. Now it is giving me a boot GRUB Error 17. Could anyone shed some light on what might be going on? It seems I can't win for losing.

Thanks!

Revision history for this message
Drew Meigs (drewmeigs) said :
#5

Actually, I believe I fixed this more or less on my own. I resized my /boot partition to just under 200MB. SO my current partitions lie in the ballpark of the following:
/boot =~200MB
swap =~<1GB (have 512MB RAM)
/ =~15GB

This, at least for now, seems to have me working properly.