update problem

Asked by sebas on 2008-09-29

when i try to update something or download a codec or something like that, the system say me that the sub-process /usr/bin/dpkg returned a error code (2)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu dpkg Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Bhavani Shankar (bhavi) said :
#1

there was something wrong with postfix installation that you attempted before
try:
sudo dpkg-reconfigure postfix
or
sudo dpkg-reconfigure -a

or

sudo gedit /var/lib/dpkg/statoverride

delete the postfix line

or

sudo dpkg --clear-avail

Or

if the above doesnt work

sudo apt-get -f install

Regards

Revision history for this message
sebas (scervantes) said :
#2

thanks, i do the ubuntu instalation again, if perfect now, but i am a new
ubuntu user so a i need to learnd many things like how install a program

2008/9/28 Bhavani Shankar <email address hidden>

> Your question #46633 on yelp in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/yelp/+question/46633
>
> Status: Open => Answered
>
> Bhavani Shankar proposed the following answer:
> there was something wrong with postfix installation that you attempted
> before
> try:
> sudo dpkg-reconfigure postfix
> or
> sudo dpkg-reconfigure -a
>
> or
>
> sudo gedit /var/lib/dpkg/statoverride
>
> delete the postfix line
>
> or
>
> sudo dpkg --clear-avail
>
> Or
>
> if the above doesnt work
>
> sudo apt-get -f install
>
> Regards
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.edge.launchpad.net/ubuntu/+source/yelp/+question/46633/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.edge.launchpad.net/ubuntu/+source/yelp/+question/46633
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Revision history for this message
mikejen (mikejenkinson) said :
#3

I have a similar problem and thought to ask here instead of starting a new thread.

 gnome-spell will not install even when I use -f install option and this is now blocking any other upgrades.

Cheers

Michael

Revision history for this message
mikejen (mikejenkinson) said :
#4

mmmm found a spelling mistake in var/lib/dpkg/status

the line reads:

Versign: 1.0.7-1ubuntu2

which should read

Version: 1.0.7-1ubuntu2

changed this line and now things are working normally

Cheers

Michael

Can you help with this problem?

Provide an answer of your own, or ask sebas for more information if necessary.

To post a message you must log in.