cannot install gparted

Asked by Jujuba on 2008-08-02

The following error occurs:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

When I try to run the command 'dpkg --configure -a', I get:

dpkg: requested operation requires superuser privilege

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu dpkg Edit question
Assignee:
No assignee Edit question
Solved by:
Jujuba
Solved:
Last query:
Last reply:
Revision history for this message
Michael Nagel (nailor) said :
#1

try to run:

sudo dpkg --configure -a

and provide your password, if requested by sudo

Revision history for this message
Deepak Mishra (dpux) said :
#2

installing a package is an administrative job, and in future always remember to prepend 'sudo' to such instructions.

Revision history for this message
Jujuba (tiger171031) said :
#3

Thank you everybody, but the whole problem started when I tried to update Ubuntu. In the end, my boot sector filled up, and there was just no space for anything else. I formatted my hard disk, set more space for Linux, and now everything is working fine.