dpkg error

Asked by GerardoN on 2008-07-24

When I try to install applications or update this are the error messages I've got.

sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
20 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up cron (3.0pl1-100ubuntu2) ...
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | sNN kNN]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
  -n: not really
  -f: force
dpkg: error processing cron (--configure):
 subprocess post-installation script returned error exit status 1
Setting up rsync (2.6.9-6ubuntu2) ...
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | sNN kNN]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
  -n: not really
  -f: force
dpkg: error processing rsync (--configure):
 subprocess post-installation script returned error exit status 1
Setting up acpid (1.0.4-5ubuntu9) ...
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | sNN kNN]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
  -n: not really
  -f: force
dpkg: error processing acpid (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of acpi-support:
 acpi-support depends on acpid (>= 1.0.4-1ubuntu4); however:
  Package acpid is not configured yet.
dpkg: error processing acpi-support (--configure):
 dependency problems - leaving unconfigured
Setting up apmd (3.2.2-8.1ubuntu1) ...
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | sNN kNN]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
  -n: not really
  -f: force
dpkg: error processing apmd (--configure):
 subprocess post-installation script returned error exit status 1
Setting up hotkey-setup (0.1-17ubuntu21) ...
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | sNN kNN]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
  -n: not really
  -f: force
dpkg: error processing hotkey-setup (--configure):
 subprocess post-installation script returned error exit status 1
Setting up nvidia-kernel-common (20051028+1ubuntu8) ...

************************************************************************
*
* The update-modules command is deprecated and should not be used!
*
************************************************************************

usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | sNN kNN]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
  -n: not really
  -f: force
dpkg: error processing nvidia-kernel-common (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of linux-restricted-modules-2.6.24-19-generic:
 linux-restricted-modules-2.6.24-19-generic depends on nvidia-kernel-common; however:
  Package nvidia-kernel-common is not configured yet.
dpkg: error processing linux-restricted-modules-2.6.24-19-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-restricted-modules-generic:
 linux-restricted-modules-generic depends on linux-restricted-modules-2.6.24-19-generic; however:
  Package linux-restricted-modules-2.6.24-19-generic is not configured yet.
dpkg: error processing linux-restricted-modules-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-restricted-modules-generic (= 2.6.24.19.21); however:
  Package linux-restricted-modules-generic is not configured yet.
dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-restricted-modules-2.6.24-16-generic:
 linux-restricted-modules-2.6.24-16-generic depends on nvidia-kernel-common; however:
  Package nvidia-kernel-common is not configured yet.
dpkg: error processing linux-restricted-modules-2.6.24-16-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-restricted-modules-2.6.24-17-generic:
 linux-restricted-modules-2.6.24-17-generic depends on nvidia-kernel-common; however:
  Package nvidia-kernel-common is not configured yet.
dpkg: error processing linux-restricted-modules-2.6.24-17-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-restricted-modules-2.6.24-18-generic:
 linux-restricted-modules-2.6.24-18-generic depends on nvidia-kernel-common; however:
  Package nvidia-kernel-common is not configured yet.
dpkg: error processing linux-restricted-modules-2.6.24-18-generic (--configure):
 dependency problems - leaving unconfigured
Setting up ntp (1:4.2.4p4+dfsg-3ubuntu2) ...
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | sNN kNN]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
  -n: not really
  -f: force
dpkg: error processing ntp (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of powermanagement-interface:
 powermanagement-interface depends on acpi-support (>= 0.17); however:
  Package acpi-support is not configured yet.
dpkg: error processing powermanagement-interface (--configure):
 dependency problems - leaving unconfigured
Setting up pulseaudio (0.9.10-1ubuntu1) ...
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | sNN kNN]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
  -n: not really
  -f: force
dpkg: error processing pulseaudio (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of ubuntu-desktop:
 ubuntu-desktop depends on acpi-support; however:
  Package acpi-support is not configured yet.
 ubuntu-desktop depends on acpid; however:
  Package acpid is not configured yet.
 ubuntu-desktop depends on apmd; however:
  Package apmd is not configured yet.
 ubuntu-desktop depends on hotkey-setup; however:
  Package hotkey-setup is not configured yet.
 ubuntu-desktop depends on powermanagement-interface; however:
  Package powermanagement-interface is not configured yet.
 ubuntu-desktop depends on pulseaudio; however:
  Package pulseaudio is not configured yet.
dpkg: error processing ubuntu-desktop (--configure):
 dependency problems - leaving unconfigured
Setting up sysklogd (1.5-1ubuntu1) ...
 * Stopping system log daemon... [fail]
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | sNN kNN]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
  -n: not really
  -f: force
dpkg: error processing sysklogd (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of ubuntu-minimal:
 ubuntu-minimal depends on sysklogd; however:
  Package sysklogd is not configured yet.
dpkg: error processing ubuntu-minimal (--configure):
 dependency problems - leaving unconfigured
Setting up klogd (1.5-1ubuntu1) ...
 * Stopping kernel log daemon... [ OK ]
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | sNN kNN]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
  -n: not really
  -f: force
dpkg: error processing klogd (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 cron
 rsync
 acpid
 acpi-support
 apmd
 hotkey-setup
 nvidia-kernel-common
 linux-restricted-modules-2.6.24-19-generic
 linux-restricted-modules-generic
 linux-generic
 linux-restricted-modules-2.6.24-16-generic
 linux-restricted-modules-2.6.24-17-generic
 linux-restricted-modules-2.6.24-18-generic
 ntp
 powermanagement-interface
 pulseaudio
 ubuntu-desktop
 sysklogd
 ubuntu-minimal
 klogd
E: Sub-process /usr/bin/dpkg returned an error code (1)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu dpkg Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Christoph Langner (chrissss) said :
#1

Try to boot into the recovery mode. You'll get into a menu where you've got several options. Try "dpkg - Repair broken packages".

Can you help with this problem?

Provide an answer of your own, or ask GerardoN for more information if necessary.

To post a message you must log in.