dpkg --configure -a can not go through

Asked by wfw on 2008-07-24

Hi; can any one help me to solved this problem?
I run command 'sudo dpkg --configure -a' on the terminal as required. but it stops at some stage without further responding. the terminal information looks like below:

xxx: ~$ sudo dpkg --configure -a
[sudo] password for xxx:
setting up language-pack -zh-base{1:7.10+20080205}...
generating locales ...
   zn_CN.UTF-8 ...

I run Ubuntu 7.10 on Acer Aspire 4315

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu dpkg Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Steven Rose (steveydoteu) said :
#1

Is that the entirety of what the terminal displays?

Following that does it return to a line looking similar to the following?

xxx: ~$

If so the process has completed itself and it is fine to close the terminal session.

Revision history for this message
wfw (maninakl63) said :
#2

Hi steven:

yes, it is the all of terminal displays,
the courser stays at the end of the line ; "zn_CH.UTF-8 ... | " without xxx: ~$ returned.

wfw

Revision history for this message
Steven Rose (steveydoteu) said :
#3

Well I would need to know, did you get told to run this command by the terminal, or the update manager? If so does it still ask you, or does it work as intended now.

Revision history for this message
wfw (maninakl63) said :
#4

I first run the language support with error of :
---------------------------------------------------------------
only one software managment tool allowed at same time;
 Please close the other application e.g. "Update Manager", "aptitude" or "Synaptic" at first.
------------------------------------------------------------
 actually, there are no any other software management tool running at the time.

then, i try to run synaptic package manager. it will show me the error as bellow:
-------------------------------
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.
----------------------------------
But I always failed to run sudo dpkg --configure -a on terminal and synaptic package manager keeps showing the error time to time whenever what i try.

Revision history for this message
Steven Rose (steveydoteu) said :
#5

Have you tried restarting your desktop environment and/or rebooting the system before giving it another go?

Revision history for this message
wfw (maninakl63) said :
#6

yes , i did.

Revision history for this message
Steven Rose (steveydoteu) said :
#7

I can't for the life of me think of the terminal commands you need to run. It is something so simple that I use regularly but it has escaped me, hopefully rather than having to wait for me to remember it, someone else will pop and answer in!

Revision history for this message
GadGet (alperstarr) said :
#8

i have the same problem nowadays and i m new at ubuntu too.. can anyone help ?
thanks.

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#9

Open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get clean all
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get clean all

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

Can you help with this problem?

Provide an answer of your own, or ask wfw for more information if necessary.

To post a message you must log in.