Ubuntu

"dpkg --add-architecture" not implemented in Ubuntu 12.04.1 LTS

Asked by Nik.Th. on 2013-02-12

According to "Multiarch/Implementation" on Debian Wiki
http://wiki.debian.org/Multiarch/Implementation

Ubuntu 12.04 LTS should use the command

sudo dpkg --add-architecture

to add foreign architectures .. if some user wants..

Dpkg version in Ubuntu 12.04.1 LTS is

dpkg --version

Debian `dpkg' package management program version 1.16.1.2 (amd64)

So why this command not exist in dpkg in Ubuntu 12.04.1 LTS ?
I know that I can add a foreign architecture via /etc/dpkg/dpkg.cfg.d/multiarch
but just asking about the command..

sudo dpkg --add-architecture i386

returns

"dpkg: error: unknown option --add-architecture"

lsb_release -rcd ; uname -rm

Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise
3.5.0-23-generic x86_64

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu dpkg Edit question
Assignee:
No assignee Edit question
Solved by:
Raphaël Hertzog
Solved:
2013-02-13
Last query:
2013-02-13
Last reply:
2013-02-12

I suggest you report a bug

Nik.Th. (nick-athens30) said : #2

If you are affected by the same bug, click on "Yes it affects me"

:-)

Best Raphaël Hertzog (hertzog) said : #3

Ubuntu 12.04 has an earlier implementation of multiarch where it uses the --foreign-architecture options that you see in /etc/dpkg/dpkg.cfg.d/multiarch. Newer versions of ubuntu have the latest multiarch implementation where dpkg --add-architecture is supported.

This is not a bug. I don't know what you expect. In any case, the new multiarch implementation won't be deployed to LTS 12.04 at this point.

Nik.Th. (nick-athens30) said : #4

I expected the command

sudo dpkg --add-architecture

to be functional in Ubuntu 12.04.1 LTS , because of version of dpkg (1.16.1.2ubuntu7.1) and the report at Debian Wiki

"multiarch support is present from dpkg 1.16.2 (or 1.16.0 in Ubuntu) and apt 0.8.13."

So maybe we can say to debian-wiki to change the reference ... ?

Nik.Th. (nick-athens30) said : #5

Thanks Raphaël Hertzog, that solved my question.

Nik.Th. (nick-athens30) said : #6

As I can understand two or more versions of multiarch implementation exist.

Ubuntu 12.04 has the older version where the command "--add-architecture" cannot be applied..

It would be nice to know from What version of dpkg (in Ubuntu) this command could be apllied..
but
who knows ?

Thanks

Raphaël Hertzog (hertzog) said : #7

Any Ubuntu version that has dpkg > 1.16.2, that is quantal (12.10) and newer.

Nik.Th. (nick-athens30) said : #8

I just added a note in Debian Wiki .. :-)

http://wiki.debian.org/Multiarch/Implementation#Using_multiarch

Thanks for clearing out this..

Thought it was a bug or something.. but Its clear now.

Nik.Th. (nick-athens30) said : #9

I saw that the note in Debian Wiki has been changed..
from
"Note that the command `dpkg --add-architecture` is not supported in Ubuntu, when dpkg is prior to 1.16.2"
to
"Note that the command `dpkg --add-architecture` is not supported in Ubuntu 12.04 LTS and earlier"

but this is not permentent .. (IMHO) .

Ubuntu 12.04 LTS will be supported until April 2017 and will receive many updates.. so maybe in a future update (12.04.3 or 12.04.4) the dpkg will support the command.. (--add-architecture)..

Isn't the first note better than the second ?

Although I will not attempt to change it again.

Thanks

Steve Langasek (vorlon) said : #10

The change to support the --add-architecture command is quite an intrusive one in the dpkg code and does not fit the Ubuntu policy for stable release updates. This will not be changed in future 12.04 point releases.

Nik.Th. (nick-athens30) said : #11

Aha..
Ok , thanks for clarify this @Steve.