Install error.... ubuntu 10.04 configure a

Asked by Sharon Sedgwick on 2011-11-28

I have now received this error several times when attempting to install Virtual Box as well as using Ubuntu Tweak in 10.04LTS
"dpkg was interrupted you must manually run 'sudo dpkg -- configure - a' to correct the problem

when i run sudo dpkg -- configure - a in the terminal this is what I get...

shivani@IAM:~$ sudo dpkg -- configure - a
[sudo] password for shivani:
dpkg: need an action option

Type dpkg --help for help about installing and deinstalling packages [*];
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;
Type dpkg --license for copyright license and lack of warranty (GNU GPL) [*].

Options marked [*] produce a lot of output - pipe it through `less' or `more' !
shivani@IAM:~$ sudo dpkg -- configure - a

I'm very new to Linux.... just trying to update and get VirtualBox installed with Ubuntu 10.04 as host... Help please... :) Thanks

Question information

English Edit question
Ubuntu dpkg Edit question
No assignee Edit question
Solved by:
Sharon Sedgwick
Last query:
Last reply:
Revision history for this message
Chris (fabricator4) said :

You appear to have the syntax slightly wrong - it should not be sudo dpkg -- configure - a, but:

sudo dpkg --configure -a

You have some extra spaces in there.


Revision history for this message
Sharon Sedgwick (journey-h) said :

Thanks so much Chris..... It appears to be working!