libc6: A copy of the C library was found in an unexpected directory

Asked by Niklas Schmidtmer on 2011-09-28

Hi,

performing an apt-get upgrade fails in the attempt to upgrade libc6:

[root@server][~] $ apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc6 : Depends: libc-bin (= 2.13-20ubuntu2) but 2.13-20ubuntu3 is installed
 libc6-dev : Depends: libc6 (= 2.13-20ubuntu3) but 2.13-20ubuntu2 is installed
E: Unmet dependencies. Try using -f.
[root@server][~] $ apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libc6
Suggested packages:
  glibc-doc
The following packages will be upgraded:
  libc6
1 upgraded, 0 newly installed, 0 to remove and 39 not upgraded.
1 not fully installed or removed.
Need to get 0 B/4301 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]?
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ...
dpkg: warning: files list file for package `libxau6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libkrb5-3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libwrap0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `gcc-4.4-base' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcupsimage2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxt6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgomp1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libasyncns0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libglib2.0-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libstdc++6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcursor1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpixman-1-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpng12-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxxf86vm1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsm6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libc6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `gcc-4.6-base' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libselinux1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcb-shape0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libjson0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libice6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libedit2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgcj-bc' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libnss3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `gcc-4.5-base' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libldap-2.4-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libavahi-client3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libvorbis0a' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `liblua5.1-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdrm-intel1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `openjdk-7-jre' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `liblcms1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpcre3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdb5.1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgnutls26' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libavahi-common3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libjasper1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsensors4' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libx11-6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxft2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libavahi-common-data' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libss2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdatrie1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libblkid1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libjpeg8' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libacl1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsasl2-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsasl2-modules' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpipeline1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxdamage1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcurl3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libnss3-1d' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsndfile1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxfixes3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdb4.8' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcomerr2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `librsvg2-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgl1-mesa-glx' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libkrb5support0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `e2fslibs' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `librtmp0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libtiff4' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libglapi-mesa' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpulse0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcb-render0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libidn11' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpcap0.8' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libattr1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxi6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpango1.0-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libexpat1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libvorbisenc2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libkeyutils1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libnspr4' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpam-cracklib' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcups2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsqlite3-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libasound2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxv1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcomposite1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgcc1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcb1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxrandr2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `zlib1g' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libmount1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdrm-radeon1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `liblcms2-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `linux-libc-dev' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libthai0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxrender1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libogg0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxext6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libfontconfig1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libudev0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpam-modules' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdrm-nouveau1a' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdrm2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libllvm2.9' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libk5crypto3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdbus-glib-1-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libquadmath0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgdk-pixbuf2.0-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `openjdk-7-jdk' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgpg-error0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpam0g' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgssapi-krb5-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libjpeg62' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcurl3-gnutls' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libtasn1-3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libuuid1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxinerama1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgcrypt11' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgdbm3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcairo2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libffi6' missing, assuming package has no files currently installed.
(Reading database ... 5%
dpkg: warning: files list file for package `libflac8' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdbus-1-3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libssl1.0.0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `openjdk-7-jre-headless' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `icedtea-7-jre-jamvm' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcb-shm0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libfreetype6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgl1-mesa-dri' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxdmcp6' missing, assuming package has no files currently installed.
(Reading database ... 70491 files and directories currently installed.)
Preparing to replace libc6 2.13-20ubuntu2 (using .../libc6_2.13-20ubuntu3_amd64.deb) ...

A copy of the C library was found in an unexpected directory:
  '/lib/x86_64-linux-gnu/libc-2.13.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib/x86_64-linux-gnu' and try again.

dpkg: error processing /var/cache/apt/archives/libc6_2.13-20ubuntu3_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.13-20ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I already went through https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure which produced the following results:

[root@server][~] $ sudo fuser -vvv /var/lib/dpkg/lock
[root@server][~] $ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu oneiric (development branch)"
[root@server][~] $ uname -r
3.0.0-12-server
[root@server][~] $ sudo rm /var/lib/apt/lists/lock
[root@server][~] $ sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
[root@server][~] $ sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
[root@server][~] $ sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
[root@server][~] $ sudo rm -rf /var/lib/dpkg/updates/*
[root@server][~] $ sudo rm -rf /var/lib/apt/lists
[root@server][~] $ sudo rm /var/cache/apt/*.bin
[root@server][~] $ sudo mkdir /var/lib/apt/lists
[root@server][~] $ sudo mkdir /var/lib/apt/lists/partial
[root@server][~] $ LANG=C;sudo apt-get clean
[root@server][~] $ LANG=C;sudo apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done
[root@server][~] $ LANG=C;sudo apt-get --purge autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc6 : Depends: libc-bin (= 2.13-20ubuntu2) but 2.13-20ubuntu3 is installed
 libc6-dev : Depends: libc6 (= 2.13-20ubuntu3) but 2.13-20ubuntu2 is installed
E: Unmet dependencies. Try using -f.
[root@server][~] $ LANG=C;sudo apt-get update -o APT::Cache-Limit=25165824
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Get:1 http://ppa.launchpad.net oneiric Release.gpg [316 B]
Ign http://archive.ubuntu.com oneiric InRelease
Ign http://archive.ubuntu.com oneiric-updates InRelease
Ign http://archive.ubuntu.com oneiric-security InRelease
Get:2 http://ppa.launchpad.net oneiric Release.gpg [316 B]
Ign http://archive.ubuntu.com oneiric-backports InRelease
Ign http://archive.ubuntu.com oneiric-proposed InRelease
Get:3 http://archive.ubuntu.com oneiric Release.gpg [198 B]
Get:4 http://archive.ubuntu.com oneiric-updates Release.gpg [198 B]
Get:5 http://archive.ubuntu.com oneiric-security Release.gpg [198 B]
Get:6 http://archive.ubuntu.com oneiric-backports Release.gpg [198 B]
Get:7 http://ppa.launchpad.net oneiric Release [9743 B]
Get:8 http://archive.ubuntu.com oneiric-proposed Release.gpg [198 B]
Get:9 http://archive.ubuntu.com oneiric Release [39.8 kB]
Get:10 http://ppa.launchpad.net oneiric Release [9742 B]
Get:11 http://archive.ubuntu.com oneiric-updates Release [23.2 kB]
Get:12 http://archive.ubuntu.com oneiric-security Release [23.2 kB]
Get:13 http://ppa.launchpad.net oneiric/main Sources [559 B]
Get:14 http://archive.ubuntu.com oneiric-backports Release [23.3 kB]
Get:15 http://ppa.launchpad.net oneiric/main amd64 Packages [742 B]
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Get:16 http://archive.ubuntu.com oneiric-proposed Release [23.2 kB]
Get:17 http://ppa.launchpad.net oneiric/main Sources [833 B]
Get:18 http://ppa.launchpad.net oneiric/main amd64 Packages [3980 B]
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Get:19 http://archive.ubuntu.com oneiric/main Sources [875 kB]
Ign http://ppa.launchpad.net oneiric/main Translation-en_GB
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_GB
Ign http://ppa.launchpad.net oneiric/main Translation-en
Get:20 http://archive.ubuntu.com oneiric/universe Sources [4682 kB]
Get:21 http://archive.ubuntu.com oneiric/multiverse Sources [149 kB]
Get:22 http://archive.ubuntu.com oneiric/restricted Sources [5321 B]
Get:23 http://archive.ubuntu.com oneiric/main amd64 Packages [1578 kB]
Get:24 http://archive.ubuntu.com oneiric/universe amd64 Packages [6382 kB]
Get:25 http://archive.ubuntu.com oneiric/multiverse amd64 Packages [171 kB]
Get:26 http://archive.ubuntu.com oneiric/restricted amd64 Packages [9230 B]
Ign http://archive.ubuntu.com oneiric/main TranslationIndex
Ign http://archive.ubuntu.com oneiric/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric/universe TranslationIndex
Get:27 http://archive.ubuntu.com oneiric-updates/main Sources [14 B]
Get:28 http://archive.ubuntu.com oneiric-updates/universe Sources [14 B]
Get:29 http://archive.ubuntu.com oneiric-updates/multiverse Sources [14 B]
Get:30 http://archive.ubuntu.com oneiric-updates/restricted Sources [14 B]
Get:31 http://archive.ubuntu.com oneiric-updates/main amd64 Packages [14 B]
Get:32 http://archive.ubuntu.com oneiric-updates/universe amd64 Packages [14 B]
Get:33 http://archive.ubuntu.com oneiric-updates/multiverse amd64 Packages [14 B]
Get:34 http://archive.ubuntu.com oneiric-updates/restricted amd64 Packages [14 B]
Ign http://archive.ubuntu.com oneiric-updates/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-updates/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-updates/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-updates/universe TranslationIndex
Get:35 http://archive.ubuntu.com oneiric-security/main Sources [14 B]
Get:36 http://archive.ubuntu.com oneiric-security/universe Sources [14 B]
Get:37 http://archive.ubuntu.com oneiric-security/multiverse Sources [14 B]
Get:38 http://archive.ubuntu.com oneiric-security/restricted Sources [14 B]
Get:39 http://archive.ubuntu.com oneiric-security/main amd64 Packages [14 B]
Get:40 http://archive.ubuntu.com oneiric-security/universe amd64 Packages [14 B]
Get:41 http://archive.ubuntu.com oneiric-security/multiverse amd64 Packages [14 B]
Get:42 http://archive.ubuntu.com oneiric-security/restricted amd64 Packages [14 B]
Ign http://archive.ubuntu.com oneiric-security/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-security/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-security/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-security/universe TranslationIndex
Get:43 http://archive.ubuntu.com oneiric-backports/main Sources [14 B]
Get:44 http://archive.ubuntu.com oneiric-backports/restricted Sources [14 B]
Get:45 http://archive.ubuntu.com oneiric-backports/universe Sources [14 B]
Get:46 http://archive.ubuntu.com oneiric-backports/multiverse Sources [14 B]
Get:47 http://archive.ubuntu.com oneiric-backports/main amd64 Packages [14 B]
Get:48 http://archive.ubuntu.com oneiric-backports/restricted amd64 Packages [14 B]
Get:49 http://archive.ubuntu.com oneiric-backports/universe amd64 Packages [14 B]
Get:50 http://archive.ubuntu.com oneiric-backports/multiverse amd64 Packages [14 B]
Ign http://archive.ubuntu.com oneiric-backports/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-backports/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-backports/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-backports/universe TranslationIndex
Get:51 http://archive.ubuntu.com oneiric-proposed/main Sources [14 B]
Get:52 http://archive.ubuntu.com oneiric-proposed/universe Sources [14 B]
Get:53 http://archive.ubuntu.com oneiric-proposed/multiverse Sources [14 B]
Get:54 http://archive.ubuntu.com oneiric-proposed/restricted Sources [14 B]
Get:55 http://archive.ubuntu.com oneiric-proposed/main amd64 Packages [14 B]
Get:56 http://archive.ubuntu.com oneiric-proposed/universe amd64 Packages [14 B]
Get:57 http://archive.ubuntu.com oneiric-proposed/multiverse amd64 Packages [14 B]
Get:58 http://archive.ubuntu.com oneiric-proposed/restricted amd64 Packages [14 B]
Ign http://archive.ubuntu.com oneiric-proposed/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-proposed/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-proposed/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-proposed/universe TranslationIndex
Get:59 http://archive.ubuntu.com oneiric/main Translation-en_GB [69.0 kB]
Get:60 http://archive.ubuntu.com oneiric/main Translation-en [699 kB]
Get:61 http://archive.ubuntu.com oneiric/multiverse Translation-en_GB [68.5 kB]
Get:62 http://archive.ubuntu.com oneiric/multiverse Translation-en [93.1 kB]
Get:63 http://archive.ubuntu.com oneiric/restricted Translation-en_GB [1937 B]
Get:64 http://archive.ubuntu.com oneiric/restricted Translation-en [2229 B]
Get:65 http://archive.ubuntu.com oneiric/universe Translation-en_GB [4365 B]
Get:66 http://archive.ubuntu.com oneiric/universe Translation-en [3166 kB]
Ign http://archive.ubuntu.com oneiric-updates/main Translation-en_GB
Ign http://archive.ubuntu.com oneiric-updates/main Translation-en
Ign http://archive.ubuntu.com oneiric-updates/multiverse Translation-en_GB
Ign http://archive.ubuntu.com oneiric-updates/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-updates/restricted Translation-en_GB
Ign http://archive.ubuntu.com oneiric-updates/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-updates/universe Translation-en_GB
Ign http://archive.ubuntu.com oneiric-updates/universe Translation-en
Ign http://archive.ubuntu.com oneiric-security/main Translation-en_GB
Ign http://archive.ubuntu.com oneiric-security/main Translation-en
Ign http://archive.ubuntu.com oneiric-security/multiverse Translation-en_GB
Ign http://archive.ubuntu.com oneiric-security/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-security/restricted Translation-en_GB
Ign http://archive.ubuntu.com oneiric-security/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-security/universe Translation-en_GB
Ign http://archive.ubuntu.com oneiric-security/universe Translation-en
Ign http://archive.ubuntu.com oneiric-backports/main Translation-en_GB
Ign http://archive.ubuntu.com oneiric-backports/main Translation-en
Ign http://archive.ubuntu.com oneiric-backports/multiverse Translation-en_GB
Ign http://archive.ubuntu.com oneiric-backports/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-backports/restricted Translation-en_GB
Ign http://archive.ubuntu.com oneiric-backports/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-backports/universe Translation-en_GB
Ign http://archive.ubuntu.com oneiric-backports/universe Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/main Translation-en_GB
Ign http://archive.ubuntu.com oneiric-proposed/main Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/multiverse Translation-en_GB
Ign http://archive.ubuntu.com oneiric-proposed/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/restricted Translation-en_GB
Ign http://archive.ubuntu.com oneiric-proposed/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/universe Translation-en_GB
Ign http://archive.ubuntu.com oneiric-proposed/universe Translation-en
Fetched 18.1 MB in 10s (1760 kB/s)
Reading package lists... Done
[root@server][~] $ sudo dpkg --clear-avail
[root@server][~] $ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of libc6-dev:
 libc6-dev depends on libc6 (= 2.13-20ubuntu3); however:
  Version of libc6 on system is 2.13-20ubuntu2.
dpkg: error processing libc6-dev (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libc6-dev
[root@server][~] $ LANG=C;sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libc6
Suggested packages:
  glibc-doc
The following packages will be upgraded:
  libc6
1 upgraded, 0 newly installed, 0 to remove and 39 not upgraded.
1 not fully installed or removed.
Need to get 4301 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]?
Abort.
[root@server][~] $ LANG=C;sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libc6
Suggested packages:
  glibc-doc
The following packages will be upgraded:
  libc6
1 upgraded, 0 newly installed, 0 to remove and 39 not upgraded.
1 not fully installed or removed.
Need to get 4301 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://archive.ubuntu.com/ubuntu/ oneiric/main libc6 amd64 2.13-20ubuntu3 [4301 kB]
Fetched 4301 kB in 3s (1194 kB/s)
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ...
dpkg: warning: files list file for package `libxau6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libkrb5-3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libwrap0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `gcc-4.4-base' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcupsimage2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxt6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgomp1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libasyncns0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libglib2.0-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libstdc++6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcursor1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpixman-1-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpng12-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxxf86vm1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsm6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libc6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `gcc-4.6-base' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libselinux1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcb-shape0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libjson0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libice6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libedit2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgcj-bc' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libnss3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `gcc-4.5-base' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libldap-2.4-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libavahi-client3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libvorbis0a' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `liblua5.1-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdrm-intel1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `openjdk-7-jre' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `liblcms1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpcre3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdb5.1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgnutls26' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libavahi-common3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libjasper1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsensors4' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libx11-6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxft2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libavahi-common-data' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libss2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdatrie1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libblkid1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libjpeg8' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libacl1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsasl2-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsasl2-modules' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpipeline1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxdamage1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcurl3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libnss3-1d' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsndfile1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxfixes3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdb4.8' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcomerr2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `librsvg2-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgl1-mesa-glx' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libkrb5support0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `e2fslibs' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `librtmp0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libtiff4' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libglapi-mesa' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpulse0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcb-render0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libidn11' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpcap0.8' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libattr1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxi6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpango1.0-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libexpat1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libvorbisenc2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libkeyutils1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libnspr4' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpam-cracklib' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcups2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libsqlite3-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libasound2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxv1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcomposite1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgcc1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcb1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxrandr2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `zlib1g' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libmount1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdrm-radeon1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `liblcms2-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `linux-libc-dev' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libthai0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxrender1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libogg0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxext6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libfontconfig1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libudev0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpam-modules' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdrm-nouveau1a' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdrm2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libllvm2.9' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libk5crypto3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdbus-glib-1-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libquadmath0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgdk-pixbuf2.0-0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `openjdk-7-jdk' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgpg-error0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libpam0g' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgssapi-krb5-2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libjpeg62' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcurl3-gnutls' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libtasn1-3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libuuid1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxinerama1' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgcrypt11' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgdbm3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libcairo2' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libffi6' missing, assuming package has no files currently installed.
(Reading database ... 5%
dpkg: warning: files list file for package `libflac8' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libdbus-1-3' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libssl1.0.0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `openjdk-7-jre-headless' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `icedtea-7-jre-jamvm' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxcb-shm0' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libfreetype6' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgl1-mesa-dri' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libxdmcp6' missing, assuming package has no files currently installed.
(Reading database ... 70491 files and directories currently installed.)
Preparing to replace libc6 2.13-20ubuntu2 (using .../libc6_2.13-20ubuntu3_amd64.deb) ...

A copy of the C library was found in an unexpected directory:
  '/lib/x86_64-linux-gnu/libc-2.13.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib/x86_64-linux-gnu' and try again.

dpkg: error processing /var/cache/apt/archives/libc6_2.13-20ubuntu3_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.13-20ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[root@server][~] $ LANG=C;sudo apt-get --fix-missing install
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc6 : Depends: libc-bin (= 2.13-20ubuntu2) but 2.13-20ubuntu3 is installed
 libc6-dev : Depends: libc6 (= 2.13-20ubuntu3) but 2.13-20ubuntu2 is installed
E: Unmet dependencies. Try using -f.
[root@server][~] $ LANG=C;sudo apt-get update -o APT::Cache-Limit=25165824 && sudo apt-get dist-upgrade
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Hit http://ppa.launchpad.net oneiric Release.gpg
Hit http://ppa.launchpad.net oneiric Release.gpg
Ign http://archive.ubuntu.com oneiric InRelease
Ign http://archive.ubuntu.com oneiric-updates InRelease
Ign http://archive.ubuntu.com oneiric-security InRelease
Hit http://ppa.launchpad.net oneiric Release
Ign http://archive.ubuntu.com oneiric-backports InRelease
Ign http://archive.ubuntu.com oneiric-proposed InRelease
Hit http://archive.ubuntu.com oneiric Release.gpg
Hit http://archive.ubuntu.com oneiric-updates Release.gpg
Hit http://archive.ubuntu.com oneiric-security Release.gpg
Hit http://ppa.launchpad.net oneiric Release
Hit http://archive.ubuntu.com oneiric-backports Release.gpg
Hit http://archive.ubuntu.com oneiric-proposed Release.gpg
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://archive.ubuntu.com oneiric Release
Hit http://archive.ubuntu.com oneiric-updates Release
Hit http://archive.ubuntu.com oneiric-security Release
Hit http://archive.ubuntu.com oneiric-backports Release
Hit http://ppa.launchpad.net oneiric/main amd64 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://archive.ubuntu.com oneiric-proposed Release
Hit http://archive.ubuntu.com oneiric/main Sources
Hit http://archive.ubuntu.com oneiric/universe Sources
Hit http://archive.ubuntu.com oneiric/multiverse Sources
Hit http://archive.ubuntu.com oneiric/restricted Sources
Hit http://archive.ubuntu.com oneiric/main amd64 Packages
Hit http://ppa.launchpad.net oneiric/main amd64 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://archive.ubuntu.com oneiric/universe amd64 Packages
Hit http://archive.ubuntu.com oneiric/multiverse amd64 Packages
Hit http://archive.ubuntu.com oneiric/restricted amd64 Packages
Ign http://archive.ubuntu.com oneiric/main TranslationIndex
Ign http://archive.ubuntu.com oneiric/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric/universe TranslationIndex
Hit http://archive.ubuntu.com oneiric-updates/main Sources
Hit http://archive.ubuntu.com oneiric-updates/universe Sources
Hit http://archive.ubuntu.com oneiric-updates/multiverse Sources
Hit http://archive.ubuntu.com oneiric-updates/restricted Sources
Hit http://archive.ubuntu.com oneiric-updates/main amd64 Packages
Hit http://archive.ubuntu.com oneiric-updates/universe amd64 Packages
Hit http://archive.ubuntu.com oneiric-updates/multiverse amd64 Packages
Hit http://archive.ubuntu.com oneiric-updates/restricted amd64 Packages
Ign http://archive.ubuntu.com oneiric-updates/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-updates/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-updates/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-updates/universe TranslationIndex
Hit http://archive.ubuntu.com oneiric-security/main Sources
Hit http://archive.ubuntu.com oneiric-security/universe Sources
Hit http://archive.ubuntu.com oneiric-security/multiverse Sources
Hit http://archive.ubuntu.com oneiric-security/restricted Sources
Hit http://archive.ubuntu.com oneiric-security/main amd64 Packages
Hit http://archive.ubuntu.com oneiric-security/universe amd64 Packages
Hit http://archive.ubuntu.com oneiric-security/multiverse amd64 Packages
Hit http://archive.ubuntu.com oneiric-security/restricted amd64 Packages
Ign http://archive.ubuntu.com oneiric-security/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-security/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-security/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-security/universe TranslationIndex
Hit http://archive.ubuntu.com oneiric-backports/main Sources
Hit http://archive.ubuntu.com oneiric-backports/restricted Sources
Hit http://archive.ubuntu.com oneiric-backports/universe Sources
Hit http://archive.ubuntu.com oneiric-backports/multiverse Sources
Hit http://archive.ubuntu.com oneiric-backports/main amd64 Packages
Hit http://archive.ubuntu.com oneiric-backports/restricted amd64 Packages
Hit http://archive.ubuntu.com oneiric-backports/universe amd64 Packages
Hit http://archive.ubuntu.com oneiric-backports/multiverse amd64 Packages
Ign http://archive.ubuntu.com oneiric-backports/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-backports/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-backports/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-backports/universe TranslationIndex
Hit http://archive.ubuntu.com oneiric/main Translation-en_GB
Hit http://archive.ubuntu.com oneiric/main Translation-en
Hit http://archive.ubuntu.com oneiric-proposed/main Sources
Hit http://archive.ubuntu.com oneiric-proposed/universe Sources
Hit http://archive.ubuntu.com oneiric-proposed/multiverse Sources
Hit http://archive.ubuntu.com oneiric-proposed/restricted Sources
Hit http://archive.ubuntu.com oneiric-proposed/main amd64 Packages
Hit http://archive.ubuntu.com oneiric-proposed/universe amd64 Packages
Hit http://archive.ubuntu.com oneiric-proposed/multiverse amd64 Packages
Hit http://archive.ubuntu.com oneiric-proposed/restricted amd64 Packages
Ign http://archive.ubuntu.com oneiric-proposed/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-proposed/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-proposed/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-proposed/universe TranslationIndex
Hit http://archive.ubuntu.com oneiric/multiverse Translation-en_GB
Hit http://archive.ubuntu.com oneiric/multiverse Translation-en
Hit http://archive.ubuntu.com oneiric/restricted Translation-en_GB
Hit http://archive.ubuntu.com oneiric/restricted Translation-en
Hit http://archive.ubuntu.com oneiric/universe Translation-en_GB
Hit http://archive.ubuntu.com oneiric/universe Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_GB
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_GB
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://archive.ubuntu.com oneiric-updates/main Translation-en_GB
Ign http://archive.ubuntu.com oneiric-updates/main Translation-en
Ign http://archive.ubuntu.com oneiric-updates/multiverse Translation-en_GB
Ign http://archive.ubuntu.com oneiric-updates/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-updates/restricted Translation-en_GB
Ign http://archive.ubuntu.com oneiric-updates/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-updates/universe Translation-en_GB
Ign http://archive.ubuntu.com oneiric-updates/universe Translation-en
Ign http://archive.ubuntu.com oneiric-security/main Translation-en_GB
Ign http://archive.ubuntu.com oneiric-security/main Translation-en
Ign http://archive.ubuntu.com oneiric-security/multiverse Translation-en_GB
Ign http://archive.ubuntu.com oneiric-security/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-security/restricted Translation-en_GB
Ign http://archive.ubuntu.com oneiric-security/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-security/universe Translation-en_GB
Ign http://archive.ubuntu.com oneiric-security/universe Translation-en
Ign http://archive.ubuntu.com oneiric-backports/main Translation-en_GB
Ign http://archive.ubuntu.com oneiric-backports/main Translation-en
Ign http://archive.ubuntu.com oneiric-backports/multiverse Translation-en_GB
Ign http://archive.ubuntu.com oneiric-backports/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-backports/restricted Translation-en_GB
Ign http://archive.ubuntu.com oneiric-backports/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-backports/universe Translation-en_GB
Ign http://archive.ubuntu.com oneiric-backports/universe Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/main Translation-en_GB
Ign http://archive.ubuntu.com oneiric-proposed/main Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/multiverse Translation-en_GB
Ign http://archive.ubuntu.com oneiric-proposed/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/restricted Translation-en_GB
Ign http://archive.ubuntu.com oneiric-proposed/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/universe Translation-en_GB
Ign http://archive.ubuntu.com oneiric-proposed/universe Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc6 : Depends: libc-bin (= 2.13-20ubuntu2) but 2.13-20ubuntu3 is installed
 libc6-dev : Depends: libc6 (= 2.13-20ubuntu3) but 2.13-20ubuntu2 is installed
E: Unmet dependencies. Try using -f.

Any help on how to properly upgrade libc6 would be greatly appreciated.

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu dpkg Edit question
Assignee:
No assignee Edit question
Solved by:
Niklas Schmidtmer
Solved:
2011-09-28
Last query:
2011-09-28
Last reply:
Niklas Schmidtmer (schmidtmer) said : #1

I was able to reproduce the warnings about missing file lists in a VM by applying an upgrade to dpkg 1.16.1~oneiric+1. This was pulled in by a Redmine PPA (https://launchpad.net/~ondrej/+archive/redmine?field.series_filter=oneiric).

Niklas Schmidtmer (schmidtmer) said : #2

dpkg is working fine again after downgrading to 1.16.0.3ubuntu4.