General question about debs and launchpad compiling

Asked by Matheus Cavalcante on 2011-02-12

In these last days I've been testing put programs in my PPA and create my own debs. But I can't. I create the tree in the directory which I'm working (something like ~/program-0.1.0/usr/program/executable.sh), I create the control, copyright, rules and then use a `debuild -S -sa`. However, my debs are almost empty. All the tree that I had create isn't included in the deb.

Using a `debuild -S`, is created just a tar.gz, in which all my tree is. But when I try to push to Launchpad and the program is compiled, what I get is a empty program, just as the deb that i create locally (You can see that in my PPA, in which there's a tar.gz file with 30 KB and a deb with 3 KB). I tried `dh_install` and `dh_installdirs`, but they don't work. Is there any configuration that I am missing?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu dpkg Edit question
Assignee:
No assignee Edit question
Solved by:
Philip Muškovac
Solved:
2011-02-13
Last query:
2011-02-13
Last reply:
2011-02-13
Best Philip Muškovac (yofel) said : #1

If you don't have a Makefile for your application that installs the application with 'make install' - then you need an install file
debian/<binary_package_name>.install

there put the files you want installed.

usr/*

for example.

Matheus Cavalcante (suetamac) said : #2

Thanks Philip Muškovac, that solved my question.