Humble Indie Bundle #2 Installation Woes!

Asked by Travis Patocka on 2011-01-12

I am running Ubuntu Hardy Heron and recently purchased the Humble Indie Bundle #2 game package over the holidays. I was excited to see that I could download and play on my Linux based system some new and exciting video games.

I tried to install Revenge of the titans and the package installer was running along smoothly until it hit its 3rd or 5th package to install and then nothing happened. My machine sat there for about 30 minutes and nothing happened. So, I restarted my machine, because I was unable to force quit the installer as I don't know how to do this yet (I am new to Linux so please be patient) Now when I try to re-downlad and install Revenge of the Titans I get a message on the screen that says the following... "Only one software management tool is allowed to run at the same time. Please close the other application e.g. update manager, synaptic or aptitude first."

How do I close another application? Is there a key combination I can press to bring up a window that will allow me to force quit on a program or software management tool? I tried my systems help menu but can't find anything usable.

I am pretty disappointed about this as I thought it would go more smoothly.

Any advice you could give me would be greatly appreciated. I love Ubuntu but have little experience running the terminal. Thanks!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu dpkg Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2011-01-14
Last query:
2011-01-14
Last reply:
2011-01-13

As you have bought the package I suggest you contact the seller as your supoprt is with them. What is the method of install? What files are involved?

Manfred Hampl (m-hampl) said : #2

The background of the message "Only one software management tool is allowed to run at the same time. Please close the other application e.g. update manager, synaptic or aptitude first." is a s follows:

Only one program that installes/removes applications can run at the same time. (Imagine you install a package that depends on another package, but in another window you deinstall that package in the same moment).

To ensure that only one of these programs can run at the same time, a 'lock' file is created by each of these programs (e.g. update manager, synaptic, aptitude...) and is removed again when that program ends. In case that one of these programs crashes or gets forcefully killed etc. the lock file might be left in place, and each subsequent starting of an application to do software updates will fail with the abovementioned message.

If you are really sure that no other software package management program is running, you might manually release this lock by issuing the command
sudo rm -f /var/lib/dpkg/lock

Ok you can only have 1 package app accessing the packages at one time. Make sure software centre is not open and that updates are not running.

If both are closed then run:

sudo fuser -vki /var/lib/dpkg/lock;sudo dpkg --configure -a

And it will free up the packages, you should now be able to do what you need once the command has ran

Travis Patocka (travisp11) said : #4

Hey everyone, thank you for your support and quick reply. So far, I have received two identical pieces of advice on how to fix my problem, but what I need is a step-by-step on where to go so that I can issue the following command...

sudo rm -f /var/lib/dpkg/lock

Is this something that needs to be carried out using the terminal?

The command up above looks familiar to what my system told me that needed to be done so I am sure that this will unlock or shut down my software installer.

Is all that I would need to do would be to type in the the above "sudo" command in the terminal window. If that is all, I think my previous days working with DOS should come back to me and I will be able to fix my problem.

Anyone else out there purchase and install the Humble Indie Bundle #2 and run into these problems?

Thank you for all of your support so far and you guys always have the answers!!

Best Manfred Hampl (m-hampl) said : #5

Travis, you are right, you have to enter that command in a terminal window.

To enter the command open a terminal (ctrl+alt+T, or from applications menu), then cut and paste

sudo rm -f /var/lib/dpkg/lock

This command will ask for your password to be entered. Please note that when typing the password it will not show any feedback (no echo, no asterisk signs,...).

This should unlock the software installer programs. Afterwards you will be able to start the installation of your software package again.- Have fun!

Travis Patocka (travisp11) said : #6

Thanks Manfred Hampl, that solved my question.