Ubuntu 10.10 Dokuwiki package: How to use the install?

Asked by Espen Klem

Not sure if this package is the same, or installed the same way as the default Dokuwiki on the new 10.10, but:

I've installed the Dokuwiki package, and wonder how to use it. Do I symlink a folder from /var/www to /var/lib/dokuwiki/ or set up a subdomain/domain to point at /var/lib/dokuwiki/ or something completely different?

Best regards,
Espen Klem

Question information

English Edit question
Ubuntu dokuwiki Edit question
No assignee Edit question
Solved by:
Lars Lindgren
Last query:
Last reply:
Revision history for this message
Espen Klem (eklem) said :

Ok, forgot to mention that I've checked for man-pages, and have installed Dokuwiki manually before. Just need the "missing link" on how Dokuwiki is thought to be used.

So, after installing w/ "aptitude install dokuwiki", what do I do? I've got Apache and php running already.

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Espen Klem (eklem) said :

Still wondering, but nobody reads this, question not understandable, or not interesting enough? Not grumpy, just wondering =)

Revision history for this message
Best Lars Lindgren (lln) said :

It seems that this Debian package doesn't get all the file permissions right. I got this working for 10.10:

sudo apt-get install dokuwiki
sudo chown www-data /etc/dokuwiki
sudo chown www-data /etc/dokuwiki/local.php
sudo chown www-data /var/lib/dokuwiki/lib/plugins

Then just go to http://localhost/dokuwiki.

Note that /etc/dokuwiki/apache.conf is limiting access to localhost, so you have to change that to "allow from all" be reachable globally (and restart Apache of course: sudo apache2ctl graceful).

According to the Debian specifics at http://www.dokuwiki.org/Install they have rearranged the files to follow their policy so the install.php-script show loads of errors even when everything is working ok. Nothing to worry about and you don't have to run that script anyway. :-)

Revision history for this message
Espen Klem (eklem) said :

Thanks Lars Lindgren, that solved my question.