Outdated package

Asked by Eric Eikrem on 2018-09-14

Just wondering why the package in apt is just 1.13.1. It is pretty outdated...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu docker.io Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-09-15
Last query:
2018-09-15
Last reply:
2018-09-14
Manfred Hampl (m-hampl) said : #1

The official sources show higher version numbers than the one that you mentioned.

For diagnostic purposes, what is the output of the commands:

uname -a
lsb_release -crid
apt-cache policy docker.io

~$ docker --version
Docker version 1.13.1, build 092cba3

~$ uname -a
Linux ubuntu-server 4.13.0-46-generic #51-Ubuntu SMP Tue Jun 12 12:36:29 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 17.10
Release: 17.10
Codename: artful

~$ apt-cache policy docker.io
docker.io:
  Installed: 1.13.1-0ubuntu6
  Candidate: 1.13.1-0ubuntu6
  Version table:
 *** 1.13.1-0ubuntu6 500
        500 http://es.archive.ubuntu.com/ubuntu artful/universe amd64 Packages
        100 /var/lib/dpkg/status

Best Manfred Hampl (m-hampl) said : #3

Ubuntu 17.10 is not supported any more and has not received any updates since July 2018
see https://wiki.ubuntu.com/Releases

If you switch to a supported Ubuntu version, you will see an updated version of docker.io (e.g. 17.03.2 in xenial, 17.12.1 in bionic)

Thanks Manfred Hampl, that solved my question.