A possible bug in version 2.76-4 of dnsmasq package?

Asked by Sadi Yumuşak on 2016-12-24

I use dnsmasq along with a long list of domains blocked in order to prevent spyware, malware, etc. on my personal computer.
I've begun having frequent DNS problems after upgrading my Ubuntu system from 16.04 to 16.10.
From time to time a random URL address suddenly becomes unreachable with varying error messages, most common one that I remember is some sort of a DNS ERROR.
I've found that the only remedy is this "sudo /etc/init.d/dnsmasq restart".
After that the problem disappears - for some time.
Such URL addresses cannot be accessed system-wide until dnsmasq service is restarted, but they can be accessed via Tor Browser only, which bypasses dnsmasq I guess.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu dnsmasq Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2016-12-24
Last query:
2016-12-24
Last reply:
2016-12-24

I suggest you report a bug. You can work around it by having a crontab to restart the service every hour or so.

Sadi Yumuşak (sa-yu) said : #2

OK, thanks, will do. But a crontab wouldn't be helpful I guess. For it occurs very sporadically, sometimes after several hours, sometimes after several minutes or so.

Sadi Yumuşak (sa-yu) said : #3

Thanks actionparsnip, that solved my question.