Why is GCC using i486 and no i686

Asked by Tomi Urankar

On my low end notebook I am setting up GENTOO with the help of DISTCC to do the compiles on my desktop computer which has Hardy 32bit ATHLON 6000+

The problem is that Hardy uses:
Target: i486-linux-gnu
and GENTOO uses
Target: i686-linux-gnu

Is there a way to set Hardy to also use i686?

Question information

English Edit question
Ubuntu distcc Edit question
No assignee Edit question
Solved by:
Tomi Urankar
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :

This may help you: http://ubuntuforums.org/showthread.php?t=116049

Hope this helps

Revision history for this message
Tomi Urankar (tomi0) said :

I know about the workaround but it doesn't always work on gentoo. Just now I am having a problem compiling XML parser because DISTCC is complaining the I686-linux-gnu doesn't exist.

In theory what would I have to do to get DARDY on Target: i686-linux-gnu

Revision history for this message
Tomi Urankar (tomi0) said :

upon more examination I found that I need to set up a cross compile on UBUNTU so the GENTOO would be using different C libraries for DISTCC.
How do I do that?

Revision history for this message
Tomi Urankar (tomi0) said :

Compiled my own GCC into a seperate folder and now it works.
tom@tomi:/$ /opt/gcc-4.1.2//bin/gcc -v
Using built-in specs.
Target: i686-pc-linux-gnu
Configured with: ./configure --prefix=/opt/gcc-4.1.2/ --target=i686-pc-linux-gnu --enable-bootstrap --with-gcc --enable-threads
Thread model: posix
gcc version 4.1.2